3

I have configured the SDL Web 8 Deployer as a standalone microservice. When I try to start the service, I get this error in the logs:

2016-04-06 10:36:37,873 ERROR SpringApplication - Application startup failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'deployerController': Invocation of init method failed; nested exception is com.sdl.delivery.configuration.ConfigurationException: License file 'cd_licenses.xml' could not be found.

In the cd_storage_conf.xml file of the service, I have the following:

<License Location="C:\Program Files (x86)\SDL Web\config\cd_licenses.xml"/>

I have also tried these variants:

<License Location="C:\\Program Files (x86)\\SDL Web\\config\\cd_licenses.xml"/>
<License Location="C:/Program Files (x86)/SDL Web/config/cd_licenses.xml"/>

In the configuration of my Content service, I have the following, and it works:

<License Location="C:\Program Files (x86)\SDL Web\config\cd_licenses.xml"/>

If I copy the license file into the config folder of the Deployer service, it works correctly, but I'd rather keep my license file in a single location.

Why does the Deployer appear to work differently to the other (apparently similar) services, and how can I get it to accept the license location? Is there something else that needs to be configured in addition to the storage conf? (I tried adding a License element at the bottom of the cd_deployer_conf.xml, but I got a schema validation error.)

  • 4
    Have you configured the license file in the "cd_deployer_conf.xml" also? because the deployerController must be using cd_deployer_config file. – Raúl Escudero Apr 6 '16 at 9:00
4

Check your other configuration files. You probably also need a License location configured in your cd_deployer_conf.xml

  • 1
    This was indeed the problem. My mistake had been to interpret the schema validation message as meaning that I shouldn't have a License element in the deployer config. In fact, it is allowed but not at the bottom of the Deployer element, which is where I'd placed it. – Dominic Cronin Apr 6 '16 at 9:08
  • 2
    didn't you see my comment before this answer? – Raúl Escudero Apr 6 '16 at 9:10
  • Thanks Raul. Unfortunately I can't accept answers from both of you. I hope everyone votes up your comments though. – Dominic Cronin Apr 6 '16 at 9:13
  • There's no conspiracy... Stack Exchange was not the only place this question was discussed ;) i.imgur.com/mlRHjMp.jpg – David Forster Apr 6 '16 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.