Web 8.1.1 CU1

I am getting the following error on publishing the HelloWorld page

Transport failed: Could not transport tcm_0-1003-66560.Content.zip using HTTPS, cause: Forbidden

From transport service log:

2016-04-19 16:53:02,362 ERROR BaseHTTPSTransportConnector - An unexpected error occurred while polling: reason: Forbidden
2016-04-19 16:53:02,593 ERROR BaseHTTPSTransportConnector - Unable to send TransportPackage to url: cause: Forbidden

Discovery registration is done. Not sure what I am missing.

  • "Forbidden" looks like a permissions issue. Hit the httpupload URL manually via a browser and see if you get the same error. If you do, it's your server security settings. Btw, are you on .net or java (if the latter, which app server)? Apr 20 '16 at 11:31
  • In addition to what Nick said, I would check your Authentication settings in the Ambient Configuration for your deployer. Are the "Use OAuth" and Enable Rules set to true? If so have you used a matching Username and Password in the creation of your publication target? Also are you using Topology Manager or the old style publishing? Apr 20 '16 at 12:16
  • OAuth is false and Enable Rules is also set to false. Using the Topology manager and this is a fresh install on single machine. Hitting the url on browser just shows a blank page. And it is .NET.
    – Vikaskr
    Apr 20 '16 at 13:32
  • Are you running the Deployer as a Standalone Service or in a Web Application? Is there anything in your deployer or core logs on the CD side? Apr 20 '16 at 13:51
  • 1
    we had the exact same error while publishing and was resolved by setting OAuth to false & Enable rules to false in the deployer's ambient_conf. In this way it bypasses the permissions while transporting package to deployer.Also as it is running as a service you will see it in services not in IIS.
    – Ashutosh
    May 9 '16 at 10:04

Thanks Chris and Ashutosh, the problem was that i set OAuth to false & Enable rules to false but did not restart the service. silly me..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.