5

I am upgrading to SDL Web 8 from SDL Tridion 2013. I have done the deployments, configuration as per SDL documentation here. I am now trying to add website using Add-TtmWebsite but getting error. cd_core log files show following error

INFO BatchUnmarshaller - Multipart unmarshaller invoked with POST http://XXX.XXX.XXX.X/discovery.svc/$batch DEBUG ODataMessageRouter - Sending error message for exception: com.sdl.odata.api.parser.ODataUriParseException: string matching regex \z' expected buth' found at com.sdl.odata.parser.ODataUriParser.parseUri(ODataUriParser.scala:34) ~[odata_parser-2.0.0-1218.jar:2.0.0-1218] at com.sdl.odata.service.actor.ODataBatchProcessorActor.createODataUri$1(ODataBatchProcessorActor.scala:119) ~[odata_service-2.0.0-1218.jar:2.0.0-1218]

I have tried to find cause of this error but no success. Checked capabilities as suggested here. updated registration also but no luck. Please suggest what could cause this error or how/where I should look further. Many Thanks

  • 2
    would be useful if you add complete command used to add website. – vinayknl Apr 22 '16 at 14:09
  • Not really a solution, but you can try disabling the oauth and check with the command again. In the cd_ambient_config.xml, set the following to false: <Security OAuthEnabled="false"> <Rules Enabled="false"/> – Vikaskr Apr 25 '16 at 8:00
  • @vinayknl I'm using this command to add website: Add-TtmWebsite -Id CMSPublishingId -CdEnvironmentId CdEnvironmentStaging -BaseUrls "XXX.XXX.XXX.X" – wads May 17 '16 at 10:05
1

There was a similar error noted when we have Discovery service deployed at port 80. As a workaround, deploying discovery with port other than 80 should resolve this error. Can you please check if this is the case here too ?

  • 1
    thanks vinayknl, yes, I got support from SDL for this issue and deploying Discovery to 8002 port resolved it. SDL plans to fix this issue in upcoming release SDL Web 8.1.2 which is scheduled at the end of July. – wads May 31 '16 at 3:53
2

First, I would suggest to confirm you have a valid and working Discovery service. This can be done with the new discovery-registration.jar file. Copy this to the location of your cd_storage_conf and then in the command prompt run this command:

java -jar discovery-registration.jar read

If this does not work, then you can also try updating the capabilities:

java -jar discovery-registration.jar update

It also could be an issue with OAuth. In the cd_ambient file located where the discovery service is installed, you have several roles, with users and passwords. These are OAuth users (not Tridion CMS users) and you could leave the default accounts /passwords there while you're first testing and installing.

If you modify any config files in the Discovery service folder you'll need to restart the Discovery service. Please post any interesting results you find.

  • Hi robrtc, thanks for suggestions. I couldn't reply earlier as I have to go on unplanned leave. I verified discovery service by running first command and it ok. Also, haven't changed any OAuth users. I am unable to find the cause for this issue, any further suggestions where I can try. TIA. – wads May 17 '16 at 10:01
  • I'd suggest to get the new 8.1.1 installer and try a fresh install. Also, double check that the ports you're using for the discovery service are open, etc. – robrtc May 19 '16 at 8:32
  • thanks robrtc, I am trying to get 8.1.1 installer, meanwhile I have already checked the ports for discovery service are open, Infact I have discovery service configured to port 80. – wads May 20 '16 at 5:10
  • used new 8.1.1 installer to install updates, and tried again. But no luck still getting same error. I have run out of clues now how and what else should I try. – wads May 24 '16 at 8:58
1

For similar issues encountered around using default ports 80/443 with the Discovery Service in Web 8.5, look for hotfix CD_8.5.0.5811 (or cumulative hotfixes with higher build numbers).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.