I have installed "Microsoft Visio2010 sp2" followed by "Visio Workflow Designer Client 2013 SP1".

I am able to connect the Content Manager server and get the list of workflows available, however the moment I select any workflow I get the below errors:

enter image description here

and when I select Ok I get the below error :

enter image description here

Now when I select Yes, I get the workflow diagram opened but in a readonly mode where I can't see the properties of any activity.

Let me know if I am missing anything.


  • It looks like something is corrupted within your Visio file. Can anyone else in your organization open it on another machine? May 4 '16 at 12:26
  • Yes 1 of my team member who created this workflow can open it but he has visio 2013 on his machine that is the only difference.
    – Yash
    May 4 '16 at 14:13
  • Approval Workflow[29].vdx for which you are seeing error will be available in one of the temp folder of visio , try cleaning this and all other files from that folder,restart visio and try opening the tridion's default workflow process first & then yours.
    – Ashutosh
    May 4 '16 at 14:23
  • Thanks Ashutosh, I tried after cleaning the temp files but still getting the same issue.
    – Yash
    May 4 '16 at 14:35

There was an issue with Visio cross-version diagrams saving, because Visio 2013 saved diagrams in a new format with .vsdx extension, however Visio 2011 uses .vdx and Visio Workflow Designer was able to work with old one only. There was a hotfix CM_2013.1.0.88102 to address this issue and add support for new format as well.

But note that once a diagram is saved using Visio 2013, it can not be open anymore with Visio 2010 due to incompatibility of Visio formats.

You can try to ask your team member to save Process Definition in old format from Visio 2013.


Previously I have also faced the same type of issue in our project. Below is the workaround for that

  • uninstall the Visio 2010 SP2
  • install Microsoft Visio 2010 SP1 (x86).

Then try it again.

  • Tried all the options but no luck :(.
    – Yash
    Jun 1 '16 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.