After successful DXA 1.4 installation on sdl web8.

Topology manager also configured correctly and published all the pages successfully

But try to access the web application getting this below error message. http://dxastaging.sdlweb8.indi/index.html

Server Error in '/' Application.

{"error":{"code":"4000","message":"Not possible to marshall single entity stream JSON: "}}

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Microsoft.OData.Client.DataServiceClientException: {"error":{"code":"4000","message":"Not possible to marshall single entity stream JSON: "}}

enter image description here

Any help would be highly appreciated

  • Apparently something went very wrong with trying to resolve the Publication using the Content Service. Maybe the Content Service logfile shows traces of what went wrong? Are you using 8.1.1 (SDL Web 8 CU 1) ? May 10 '16 at 19:52
  • @Rick: Yes, I installed SDL Web 8.1.1. also I did noticed this issue only happening on the servers hosting.. If I running the DXA 1.4 solution locally on my laptop and configured to connected to discovery URL then it's working fine. In the firewall i did open the all the ports.. but still that issue exist on servers.. and then I tried to hosted the DXA 1.4 web application on another server, and tried same error message same issue is coming it's very strange issue
    – Velmurugan
    May 12 '16 at 19:35
  • @RickPannekoek, Velmurugan - hi I am facing same error for all image urls on the webpage. No image is displayed on the webpage because of this error. Any idea what solve your issue ? Dec 22 '16 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.