4

On my SDL Web 8 Content Manager box I get this COM error when I call the SystemWideList on the Core Service.

Exception calling "GetSystemWideList" with "1" argument(s): "Unable to get object: LicenseInfo
Retrieving the COM class factory for component with CLSID {F470B218-7754-4943-92A5-D264627DD361} failed due to the
following error: 80004005 Unspecified error (Exception from HRESULT: 0x80004005 (E_FAIL))."
At C:\vagrant\tools\publish-site.ps1:35 char:5
+     $publicationTargets = $client.GetSystemWideList($filter);
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : FaultException`1

In this case I use Peter's Powershell Module but I have seen similar Unable to get object: LicenseInfo Retrieving the COM class factory for component errors when running the DXA install script.

The issue does not hapen every time in the same place. Also the CME works as normal now, while that also uses the Core Service. After restarting the machine the same script works fine.

What could cause such an issue?

1

This kind of error can be caused by excessive memory pressure. Are you running something on the server that is leaking memory? That would be consistent with your symptoms. Specifically - the error is intermittent, and that it improves after restarting the server.

  • The server has 10GB of RAM assigned and does not use all of that. It is a VM and this problem occurs after provisioning it, just before the errror occurs the machine has beeen a bit busy with starting up, starting Tridion services, installing stuff etc. I do not think that is unusual but it might have something to do with this error. – Jan H May 23 '16 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.