0

SDL Tridion 2011 SP1.

We have the following problem:

A page contains a wrapper component, which in turn contains a component with a text field that allows rich text formatting. Within the rich text field we have hyperlinked to a component, which is word document. The document component uses the Document schema which is of schema type 'Multimedia Schema', and 'Word document' has been selected as one of the allowed multimedia types.

When we try to publish the page (with the component which has a rich text field with a hyperlink to the document) however, the hyperlink appears as plain text on the published version of the page, rather than as a hyperlink to the document.

Are we missing something to get the hyperlink to the document (in the rich text field) to display as a hyperlink on the published page? The strange thing is that we have linked to another document within the same rich text field, and that document is referenced as a hyperlink within the content section of the page.

Any help would be greatly appreciated.

  • Did you also published that multimedia component (Word doc)? Or just the page by itself? – Robert Jin May 23 '16 at 18:45
  • wich way are the component with the RTF contained in the Component inside the Page, and how are you rendering the RTF field? Probably the way it is made, doesn't trigger the publication of the Multimedia Component. Try finding the using of the other document, that you mention the link works ok, because, probably that component is published by another template, and then the link works; but the one you are trying to see doesn't get published by your template. – Raúl Escudero May 24 '16 at 7:02
  • You can also have a look at the published page sourcecode (on server and not via view source from the page) and see what code Tridion produces for the link. Normally the Render method for an RTF field will product Tridion links for the documents. – robrtc May 24 '16 at 18:53
  • Thanks for your help with this. We currently have a 2013 environment with the same content, and it works there. What we have also found is that the RTF will only render one multimedia component link. Within the RTF we had hyperlinked to two document components, one of which rendered as a hyperlink on the published page, the other one didn't. When we removed the one that worked, and republished the page, the link that originally was not showing is now working. Hence we think the RTF can only handle one hyperlinked multimedia component in Tridion 2011. Is this a known bug in Tridion 2011 SP1? – Harald Greve May 26 '16 at 8:34
  • We also tried to debug with the template builder, and can't see anything wrong with what is produced. Both documents were rendered as hyperlinks. However, the published page only shows the latter as a hyperlink to the document. – Harald Greve May 26 '16 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.