1

Web 8.1.1 is installed and DXA 1.4 I tried to setup DXA sample site. It is configured and site is loading but some parts have an error.

Error enter image description here

Error message in log file is

2016-05-30 11:03:47,502 [26] ERROR - An error occurred while resolving evidence using the Context Service. Sdl.Web.Common.DxaException: An error occurred while resolving evidence using the Context Service. ---> Microsoft.OData.Client.DataServiceTransportException: Unable to connect to the remote server ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:8087 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetResponse() at Microsoft.OData.Client.HttpWebRequestMessage.GetResponse() --- End of inner exception stack trace ---

Any ideas?

  • 1
    Is your context service up and running and well configured? The discovery and content services seem okay from the screenshot, your issue seem to be in the context service for images. – Bart Koopman May 30 '16 at 12:06
  • Thanks, that was the problem. I followed instructions on SDL Web 8 Standalone installation and there was nothing related to context service. I installed it now and everything is ok. Thanks one more time. – Ljiljana Eric May 30 '16 at 13:46
3

Solution: Context service wasn't installed. So after installation of that service everything works fine

  • Please mark your own Answer as such. – Rick Pannekoek May 31 '16 at 17:38
1

The error suggests a connection issue, Can you access your Discovery Service from the machine you are debugging from?

Possible causes (and there could be a lot)

  1. Incorrect value for discovery-service-uri in web.config, shown below
  2. Discovery service incorrectly configured
  3. Firewall blocking Discovery service, as it runs on "unusual" port number (8087?)
  4. If enabled, incorrectly configured OAuth
  <add key="discovery-service-uri" value="http://saintjohn11.ams.dev:8082/discovery.svc" />
  • Web config has good value, also in cd_client.log there is message 2016-05-30 12:48:31 INFO [Sdl.Web.Delivery.ContentService.AutoConfigure.get_ODataV4ServiceEndpoint] - content-service endpoint found from discovery service. Discovery service is configured good. Firewall is not blocking Discovery service. – Ljiljana Eric May 30 '16 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.