1

My DXA JAVA 1.4 website throws these warnings and errors in the log.

16:10:41.157 [http-apr-8080-exec-7] WARN  c.s.w.c.impl.DefaultRegionBuilder - Could not find a model type for region Main with MvcData MvcDataImpl(controllerAreaName=Core, controllerName=Region, actionName=Region, areaName=Core, viewName=Navigation, regionAreaName=null, regionName=null, routeValues={}, metadata={})
16:10:41.157 [http-apr-8080-exec-7] ERROR c.s.w.c.impl.DefaultRegionBuilder - Could not find a model type for region Main even using a predefined region

What could cause this? The page works, and the entities in the Main region are shown.

1 Answer 1

1

The warnings and errors are in this case more debug logging and this still needs to be looked at and classified a bit better in error handling (I have discussed it a while ago with one of the developers, you see similar things happening on .NET).

I believe the problem was that there were some situations where the error actually made sense, but sounds like both of these should be classified as either INFO or DEBUG and possibly an additional error should be thrown in the error handling of these in case we actually do have a problem with the model mapping.

I suggest you log it as a defect on GitHub and I'll add it to one of the upcoming sprint backlogs.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.