6
  1. Downloaded and accessed DXA installation media.
  2. From the cms\ folder, copied the DXA Application Data Definition.xml file to %TRIDION_HOME%\config\ImportExport\ApplicationData\.
  3. Ran the ttm-prepare.ps1 script and preconfigured the Topology Manager for the DXA Site Type and Business Process Types.
  4. Ran cms-import.ps1 script specifying each parameter-value pair in the format -parameter "value".

    .\cms-import.ps1 -importType all-publications -cmsUrl "https://localhost:81/"

  5. Ran "cms-import.ps1" again and specified the following parameters to set Rights and Permissions for the default User Groups on the imported content:

    .\cms-import.ps1 -importType rights-permissions -cmsUrl "https://localhost:81/"

    Confirmed that the import created new Publications and assigned security.

enter image description here

then i tried to compile the "dxa-example-webapp" by running command

"mvn clean package -Pcd-web8"

and build failed because of following dependencies could not be resolved.

enter image description here

Tried the corrected maven command with build profile "web8" as:

mvn clean package -Pweb8

enter image description here

And the same problem persists...

  • the documentation seems to contain a typo on the profile, it should be: mvn clean package -P web8, but when I do that I'm also not able to build the dxa-example-webapp, so will have to check it out. – Bart Koopman Jun 9 '16 at 15:15
  • Yeah that's right i checked it into maven pom file, profile is "web8" instead of "cd-web8"...its a typo..i tried it with mvn clean package -Pweb8..it runs the correctly matched profile from pom..but still dependencies missing problem persists.. @BartKoopman – Javed Khan Jun 9 '16 at 15:20
2

There seem to be version mismatches between the referenced 8.1.1 CIL artifacts and the ones available on Maven Central. Furthermore, DXA uses a custom build of DD4T which needs to be registered in your local Maven repository.

In general, it may be easiest to obtain the sources from the dxa-web-application-java repository on GitHub (this includes the custom DD4T build) and build from there.

2

It seems dd4t artifacts are not in DXA distribution. Since they're custom, they're not available on Maven Central. Thus you cannot resolve them.

The correct command is mvn clean package -Pweb8 which points webapp to the right versions of CIL and DD4T. web8 profile is a default so it's activated if Maven is run without any valid profile. This means mvn clean package is exactly the same command for this webapp. The profile cd-web8 doesn't exist, so Maven actually executed mvn clean package -Pweb8 because it's default.

The actual problem is that DD4T custom artifacts couldn't be resolved. They are on GitHub, and webapp is configured to also use file:///${project.basedir}/../local-project-repo as a Maven repository. It is there for GitHub and its clones, but it's not there for ZIP distribution. Once they're failed to be resolved, the attempt is cached!

  1. The simplest solution is to copy all contents of https://github.com/sdl/dxa-web-application-java/tree/release/1.4/local-project-repo to your .m2/repository folder. Don't forget to clear Maven cache (simply remove the whole .m2/repository)
  2. The right solution is to put the local-project-repo folder next to your webapp. Also don't forget to clear Maven cache.
  3. The additional solution is to add a remote repository on GitHub https://raw.githubusercontent.com/sdl/dxa-web-application-java/release/1.4/local-project-repo using Maven's <repositories/> tag.
  • My maven project "dxa-example-website" has nothing in src/main/webapp folder. Everytime i am trying to build and run the project, it show assets/css/main.css not found and breaks. – Javed Khan Jun 28 '16 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.