1

I am trying to setup some promotional content but unable to get the TCDL markup and not recognizing the promotional content . I have checked the the prefix "smarttarget" in the page as well as in web.config file. It exist but not working.

Any suggestions?

Thanks for your help.

  • 2
    Can you please share what CM version you're on, also what Content Presentation technology and architecture, I.e. Java, .Net, and MVC or straight up JSP or Webforms, or DXA? – Nickoli Roussakov Jun 9 '16 at 19:29
  • It's pretty unclear what the issue is. What do you see in the source of your page, on disk? Does it have TCDL tags? "smarttarget:" tags? What about when you look at the source in your browser? Basically, some more details on what exactly the problem is would help troubleshooting. – Peter Kjaer Jun 10 '16 at 8:50
2

Ok, so you have checked the web config already. You need to check the following as well:

Firstly, SmartTarget modules need to be present in the cd_deployer_conf.xml. Check the <Processors> element if the TagBundle is added to TCDLEngine. If not that is the issue, try adding the TagBundle.

If it does not work then check the publication target once to confirm if the target language is same as of the language you have used in your website.(ASP/JSP)

Let me know if this information helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.