1

What are the steps to install DXA 1.4 .Net & Java content delivery website on the same machine whereas both programming language using same CMS i.e. Web 8?

Additional information: I have successfully installed .Net application both Staging & Live but after setting up Java version of DXA 1.4 I am getting no content response from the below service :

http://xx.xx.xx.xx:8081/client/v4/content.svc/GetPublicationMappingsFunctionImport(Url='http://localhost:8080')

where Dot.Net version of DXA i.e. http://xx.xx.xx.xx:8081/client/v4/content.svc/GetPublicationMappingsFunctionImport(Url='http://sdldxa.dxa.com/') return me valid response for example:

<?xml version="1.0" encoding="UTF-8"?>
<entry xmlns:metadata="http://docs.oasis-open.org/odata/ns/metadata" xmlns:data="http://docs.oasis-open.org/odata/ns/data" xmlns="http://www.w3.org/2005/Atom" metadata:context="http://xx.xx.xx.xx:8081/client/v4/content.svc/$metadata#PublicationMappings/$entity" xml:base="http://xx.xx.xx.xx:8081/client/v4/content.svc">
    <id>http://xx.xx.xx.xx:8081/client/v4/content.svc/PublicationMappings(9)</id>
    <title></title>
    <summary></summary>
    <updated>2016-06-10T05:12:38.846Z</updated>
    <author>
        <name>SDL OData v4 framework</name>
    </author>
    <link rel="edit" title="PublicationMapping" href="PublicationMappings(9)"></link>
    <category scheme="http://docs.oasis-open.org/odata/ns/scheme" term="#Tridion.ContentDelivery.PublicationMapping"></category>
    <content type="application/xml">
        <metadata:properties>
            <data:PublicationId metadata:type="Int32">9</data:PublicationId>
            <data:Protocol>http</data:Protocol>
            <data:Domain>sdldxa.dxa.com</data:Domain>
            <data:Port>80</data:Port>
            <data:Path>/</data:Path>
            <data:PathScanDepth metadata:type="Int32">100</data:PathScanDepth>
        </metadata:properties>
    </content>
</entry>

Can someone please provide pointer what is missing for no response?

Regards

Vivek

  • are both base URLs correctly registered and mapped in the Topology Manager? – Bart Koopman Jun 10 '16 at 7:49
  • Yes Bart both the URLs has correctly registered in the Topology Manager. – Vivek Kwatra Jun 10 '16 at 9:04
  • 2
    What your are describing really sound like you don't have a Publication Mapping for one of the two URLs. Can you show the output of Get-TtmWebsite and Get-TtmMapping ? – Rick Pannekoek Jun 10 '16 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.