10

I'm trying to set up Preview on an XPM-enabled site. The XPM part works fine, but when I press "Update Preview" I get this message: "Unable to preview the page. There is no publication target defined for this SiteEdit enabled website. Contact your SDL Tridion administrator".

I reviewed the documementation on http://sdllivecontent.sdl.com/ & as far as I can tell, I've set everything up per the documentation. Obviously I missed something though, but what? Any suggestions on where to look?

This is the "User Interface Update for Tridion 2011 SP1".

  • We have the exact same error. I have a ticket open with SDL now and we have gotten to the root cause of our issue...just not sure how its happening. When the call is made to GetPreviewToken, we are not sending the TCM id of the publish target like it is asking for. We are sending the parameter "publishingTargetId" as the current path of the page within the site...and that is why we are getting the error. If SDL and R&D can get back to me, i will post here. – Trevor Bartlett May 30 '14 at 21:16
8

Looks like you did not configure your Publication Target for Session Preview. In the CME, open the publication target you're using for your preview site and:

  • Click the "Enable for inline editing" check box
  • Switch to the "Session Preview" tab
  • Enter the URL of your OData endpoint for session preview
  • Add the URL(s) of your preview website(s) to the list of URLs
  • Save & Close the publication target, refresh your Page.

EDIT

This has also been mentioned as one of the steps required, though I can't find documentation references to it. Some Content Delivery modules will use the information in the cd_dynamic_conf.xml file to determine context (current publication). I doubt this is the case for you, because your error is in the CME/UI which implies a different context, but it's always worth a shot.

  • Open cd_dynamic_conf.xml
  • Add a <Publication Id='X'> node under /URLMappings/StaticMappings/Publications, where 'X' is the Item ID of your publication (not a TCM URI, the publication ID)
  • Add as many <Host Domain="url" Port="port" Protocol="http" Path="/"/> entries as needed to define all the urls your editors may use to get to this publication
  • Recycle your web application to activate changes

When you click Update Preview Tridion will try to find the Publication Target that was used to publish the current page, find the associated OData Endpoint URL and then start the "Fast Track Publishing" process. For you, it's failing to find the publication target that was used, and that's why I assumed it was a configuration issue on the target. It still is my primary suspicion, try playing around with your website URL(s) in the target.

  • Both the URL of the OData endpoint & the URL of the preview website are set on the publication target. Both are valid URL's. – Mr Smith May 29 '13 at 14:52
  • Tridion still can't find it... try adding the configuration to the cd_dynamic_conf.xml, I'll update my answer with an example – Nuno Linhares May 29 '13 at 15:05
  • You are referring to the cd_dynamic_conf.xml in my staging web site, correct? Not the one in the OData Webservice, though doesn't that need a similar entry? – Mr Smith May 29 '13 at 15:17
  • Is there any way to find the publication target that Update Preview is looking for? – Mr Smith May 29 '13 at 15:40
  • Update preview is looking for the publication target that has Session preview enabled AND the staging site's URL in the list of URLs. If you have 2 targets with the same URL it could be finding the wrong target. And yes, I mean it in the staging web site. – Nuno Linhares May 29 '13 at 15:50
3

I've seen this once recently and it was because the URL of the content manager that the "staging" website binds to for Experience Manager was still pointing to my other DTAP environment (deploy from dev->qa, publish, qa websites now connect to dev CM for Experience Manager).

The configuration for this is set as a template parameter on the template building block "Enable inline editing for Page".

The DEV content manager did not include a publication target with configuration for the QA websites hence it resulted in this error being thrown...

  • This was the case for me. I had a different website url defined in the publication target config than the actual url of the staging site. – Nickoli Roussakov Dec 4 '14 at 1:52
2

We had the exact same error. When the call was made to GetPreviewToken, we were not sending the TCM id of the publish target like it was asking for. We were sending the parameter publishingTargetId as the current path of the page within the site...and that is why we were getting the error. Check the call for GetPublicationTargetFromUrl. It should return a response of the TCM ID of the Target. Ours was not because the call for ID did not match EXACTLY to the URL that was being used. We had to drop the port 80 because IIS was removing it. Case and port must be perfect for the right ID to be returned.

Hope that helps...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.