1

We're getting a publishing failure for a few pages with the following error message:

'Committing Deployment Failed

Phase: Deployment Prepare Commit Phase failed. Unable to prepare transaction: tcm id. Unable to store item inside current transaction'

This is only happening when we are publishing to Staging. It works to publish to Live. Why might it not allow us to publish to staging?

We've found this: Tridion Deployer Unable to store item in current transaction, but are not sure that our problem is caused by a character limit, as there is nothing out of the ordinary that I can see in the components on this page.

We also found this: https://stackoverflow.com/questions/13525218/publishing-failed-in-stage-committing-deployment. Even though we have recently upgraded to 2013 SP1, the suggestion here that our Tridion Broker database is of a different version is not our problem. We have verified this by looking at the TDS_DB_INFO database table for the Tridion Broker and Session Broker databases.

  • did you check logs? – Raj Kumar Jun 29 '16 at 10:21
1

We unpublished the pages, and then sent them through to publish again. That seems to have fixed it. We're still not sure of the root cause of the original problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.