6

I am facing the issue while installing the standalone preview service for web 8.1 in a distributed environment.

My requirement is to have separate CM and CD server as distributed architecture. I have installed Web 8.1 on CM server, it is working and I am able to create items in the CMS like publications, schemas, components etc.

Now i am trying to configure content delivery on a separate server in which i have installed the Deployer service, Discovery service, Session Content services which are running as shown below:-

enter image description here

Issue is occurring while starting the preview service. Not able to connect to port 8083 as shown below

enter image description here

I have checked the port and 8083 is not used by any other process by powershell command like below screenshot

enter image description here

Also i am sure that no firewall is preventing the port 8083 on my server. Even though i have made an entry in windows firewall inbound rule for 8083 port to allow for tcp connection like below

enter image description here

I have followed the SDL docs for installing the Micro services as standalone Installing the Preview Service

Any help or pointer will be highly appreciated.

Any URL or pointer for implementing Web 8.1 in distributed architecture will very helpful.

  • I see in your first screenshot a warning that already PreviewService installed on your server! This could be the reason for the issue, to double check that put check your preview service log. Can you try removing the existing preview service and try. Also It seems to be not necessarily an port conflict issue, you can try with another available port to rule out that. – ARRX Jul 15 '16 at 8:37
  • @ARRX Initially i tried as combined micro service installation on my CD environment but i was facing another issue. All services were not operating simultaneously. If i start one service, another service got stopped. Then i decided to install the micro service as standalone. Now i am facing this issue. Even i have tried with 8085 port as well which is also free port. Thanks – SumitK Jul 15 '16 at 9:38
  • Can you check if you have something in DEBUG logs of the service ? – vinayknl Jul 15 '16 at 10:02
  • 1
    You're focusing on the port, but the issue seems to be that the service isn't starting in the first place. Most likely a configuration issue or a missing license. – Peter Kjaer Jul 15 '16 at 10:11
  • It looks you don't have sufficient permissions to start the Service. Please check the credentials in the powershell configuration file. If issue still persist please check eventviewer/service logs. – Manish Mehmood Jul 15 '16 at 10:12
2

Recently I encountered a situation as similar to your case, one of my microservice was not getting installed for some reason and hence it didn't log anything including event logs.

In that case, it is a good idea to start the service as stand alone process via command prompt or PowerShell, on the command prompt or PowerShell prompt you should be able to see the reason for the failure. This helped me to find why my service didn't install/start.

Step1: .\uninstallService.ps1 (this is because already service installed but it was not working)

Step2: .\start.ps1 (This should tell you the reason for failure, mine was missing JAVA_HOME environmnetvariable and database storage entry issues in cd_storage_conf.xml of my service lib)

Step3: After fixing the issues you have observed on step2, run ./installService.ps1

This did the trick for me.

  • Yes, @NunoLinhares database drivers are shipped with product, thanks for pointing it out, I'll update my answer. – ARRX Jul 19 '16 at 7:41
  • I did uninstalling the services earlier and then I tried to install each service as standalone. Even though i was getting the error. Finally services got installed after system format and did a fresh installation. – SumitK Jul 19 '16 at 13:14
0

After digging into the issue much deeper, from configuration to installation point of view I took each and every possible action to resolve the issue. But i was not able to resolve the issue which i suppose was related to the port which was not responding.

Finally i decided to cleanup the server with fresh copy of OS, now the all the services are installed and working on the server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.