4

This issue only appears when using Chrome. Firefox and IE(11) are working fine.

When I try to open an item I can see that the CME is loading the content and/or definition but it does not show in the CME.

When loading a Schema the Name, Description, Schema Type and Root element fields are empty and the design tab is also missing. If I try to load a Component based on that Schema the fields are not shown.

The call to the General service is made:

/WebUI/Models/TCM54/Services/General.svc/GetItem

If I look at the source tab the content of the Component is visible. This only happens with Components based on Schemas that are having the issue of not showing the fields.

I have tried to step though the JS that is loaded but there is so much going on I don't know where to look.

Anybody had this issue as well?

  • What version of Web 8 are you on exactly, the GA or the CU1? – Bart Koopman Jul 19 '16 at 9:18
  • Web8 CU1 (March 2016) – Pve Jul 19 '16 at 9:20
  • checking with latest Chrome version 51.0.2704.106 m, but not seeing the issue. Do I gather correctly you don't have it on all Schemas? – Bart Koopman Jul 19 '16 at 9:25
  • I am also using version 51.0.2704.106 m. It only happens for some Schemas. I have not been able to find a specifid type of field or something that stands out and could cause it. – Pve Jul 19 '16 at 9:27
  • Not sure if this helps but now I'm also seeing that when I close a Schema that won't load properly. The entry dissapears from the CME. It shows again when I refresh the content of the folder. It's still checked-out. When I click undo check-out it dissapears again. After refreshing it's back and has a normal state – Pve Jul 19 '16 at 9:34
1

Since you only see it on some Schemas and not all, it either sounds like you might have database performance issues (in which case I would expect it on other browsers too), or perhaps some wierd browser caching issue.

It might be a random kind of thing that only happens in Chrome, so if you can't get it solved, do report it to Customer Support.

To ensure your database is is performing optimal, you need to have ensured it is conrrectly configured and maintained. For MS SQL Server, refer to the Microsoft documentation and it can never harm to run exec sp_updatestats on the CM database. If that command seems to solve your problem, it is an indication that your database was not well maintained.

For an Oracle CM database, there is a specific maintenance chapter in the Web 8 documentation http://docs.sdl.com/LiveContent/content/en-US/SDL%20Web-v1/GUID-5863DEDC-1511-4333-A0C6-644B67403634

If database maintanance doesn't solve the issue, try clearing all cache on the browser and see if that helps, else, as mentioned contact Customer Support. As far as I know it is not a known issue in Chrome, and I haven't seen it happening myself yet.

  • The content of the component is loaded and the schema definition too. I can see the calls beign made using Fiddler. I also disabled the cache in chrome (via devtools and a extension) but that didn't help. I'll report it to Customer Support. Thanks for the suggestions! – Pve Jul 19 '16 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.