5

I am implementing DXA 1.5 with Web 8.1 in a distributed architecture. Already setup CMS and CD on separate servers successfully.

All services microservices are running on the default port as mentioned in SDL Docs.

But I am trying to hit the DXA website URL, it is throwing the below error:-

Server Error in '/' Application.

{"error":{"code":"9000","message":"java.lang.NullPointerException: null"}}

enter image description here

All pages and _System folder is already published successfully.

All services are accessible from CMS server as well.

Error in site.log error is given below however not getting any error in cd_client log of website:-

2016-07-21 18:01:16,458 [8] ERROR - Failed to execute query
Sdl.Web.Delivery.Service.ServiceQueryException: Failed to execute query ---> Microsoft.OData.Client.DataServiceQueryException: An error occurred while processing this request. ---> Microsoft.OData.Client.DataServiceClientException: {"error":{"code":"9000","message":"java.lang.NullPointerException: null"}}
   at Microsoft.OData.Client.QueryResult.ExecuteQuery()
   at Microsoft.OData.Client.DataServiceRequest.Execute[TElement](DataServiceContext context, QueryComponents queryComponents)
   --- End of inner exception stack trace ---
   at Microsoft.OData.Client.DataServiceRequest.Execute[TElement](DataServiceContext context, QueryComponents queryComponents)
   at Microsoft.OData.Client.DataServiceContext.InnerSynchExecute[TElement](Uri requestUri, String httpMethod, Nullable`1 singleResult, OperationParameter[] operationParameters)
   at Microsoft.OData.Client.DataServiceContext.Execute[TElement](Uri requestUri)
   at Sdl.Web.Delivery.Service.ODataV4Service.<>c__DisplayClass19_1`1.<Execute>b__1()
   at Sdl.Web.Delivery.Service.MemoryCacheProvider.AddOrGetExisting(String key, Func`1 addFactory, Boolean useCache)
   at Sdl.Web.Delivery.Service.ODataV4Service.<>c__DisplayClass19_0`1.<Execute>b__0()
   --- End of inner exception stack trace ---
   at Sdl.Web.Delivery.Service.AbstractODataService.HandleHttpResponseCode(Exception e, Int32 statusCode)
   at Sdl.Web.Delivery.Service.ODataV4Service.<>c__DisplayClass19_0`1.<Execute>b__0()
   at Sdl.Web.Delivery.Service.Utils.PerformRetry[T](Func`1 block, Int32 retryCount)
   at Sdl.Web.Delivery.Service.Utils.Retry[T](Func`1 block, Int32 retryCount, Boolean locking)
   at Sdl.Web.Delivery.Dynamic.DynamicMappingsRetrieverImpl.GetPublicationMapping(String url)
   at Tridion.ContentDelivery.DynamicContent.DynamicMappingsRetriever.GetPublicationMapping(String url)
   at Sdl.Web.Tridion.CdApiLocalizationResolver.ResolveLocalization(Uri url) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Tridion\CdApiLocalizationResolver.cs:line 66
   at Sdl.Web.Mvc.Configuration.WebRequestContext.get_Localization() in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Mvc\Configuration\WebRequestContext.cs:line 23
   at Sdl.Web.Mvc.Statics.StaticContentModule.BeginRequest(Object sender, EventArgs e) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Mvc\Statics\StaticContentModule.cs:line 51

Also getting some error in cd_core.log file of session microservice as given below:-

2016-07-21 18:01:16,440 ERROR ODataRendererActor - Unexpected exception during response rendering - java.lang.NullPointerException: 'null'
java.lang.NullPointerException: null
    at org.ehcache.jcache.JCache.put(JCache.java:228) ~[jcache-1.0.1.jar:na]
    at com.sdl.web.discovery.delivery.configuration.CachingConfigurationProvider.provide(CachingConfigurationProvider.java:91) ~[discovery-client-8.1.1-1009.jar:8.1.1-1009]
    at com.sdl.delivery.configuration.ConfigurationLoaderImpl.load(ConfigurationLoaderImpl.java:48) ~[cd_common_config-8.1.1-1002.jar:8.1.1-1008]
    at com.tridion.dynamiccontent.DynamicContent.loadConfiguration(DynamicContent.java:134) ~[cd_dynamic-8.1.1-1008.jar:8.1.1-1008]
    at com.tridion.dynamiccontent.DynamicContent.<init>(DynamicContent.java:94) ~[cd_dynamic-8.1.1-1008.jar:8.1.1-1008]
    at com.tridion.dynamiccontent.DynamicContent.getInstance(DynamicContent.java:79) ~[cd_dynamic-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.web.content.datalayer.dynamic.DynamicContentProvider.getPublicationMappingFromUrl(DynamicContentProvider.java:38) ~[content-common-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.web.content.odata.function.dynamic.GetPublicationMappingsFunction.doContentServiceOperation(GetPublicationMappingsFunction.java:42) ~[content-common-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.web.content.odata.function.dynamic.GetPublicationMappingsFunction.doContentServiceOperation(GetPublicationMappingsFunction.java:20) ~[content-common-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.web.content.odata.ContentServiceOperation.doOperation(ContentServiceOperation.java:36) ~[content-common-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.odata.processor.ODataFunctionProcessorImpl.doFunction(ODataFunctionProcessorImpl.java:63) ~[odata_processor-2.0.5-1002.jar:2.0.5-1002]
    at com.sdl.odata.service.actor.ODataQueryProcessorActor$$anonfun$receive$1.applyOrElse(ODataQueryProcessorActor.scala:36) ~[odata_service-2.0.5-1002.jar:2.0.5-1002]
    at akka.actor.Actor$class.aroundReceive(Actor.scala:480) ~[akka-actor_2.11-2.4.1.jar:na]
    at com.sdl.odata.service.actor.ODataQueryProcessorActor.aroundReceive(ODataQueryProcessorActor.scala:29) ~[odata_service-2.0.5-1002.jar:2.0.5-1002]
    at akka.actor.ActorCell.receiveMessage(ActorCell.scala:526) [akka-actor_2.11-2.4.1.jar:na]
    at akka.actor.ActorCell.invoke(ActorCell.scala:495) [akka-actor_2.11-2.4.1.jar:na]
    at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:257) [akka-actor_2.11-2.4.1.jar:na]
    at akka.dispatch.Mailbox.run(Mailbox.scala:224) [akka-actor_2.11-2.4.1.jar:na]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.8.0_77]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.8.0_77]
    at java.lang.Thread.run(Unknown Source) [na:1.8.0_77]

Also i have gone through another question Error on accessing website DXA 1.4 where i found that website URL will be mapped with the port number, but what if i have used port 80 with domain name which is default.

Any help would be highly appreciated.

1

Seems to be a caching issue in your CIS Content Service. I suggest to report this to SDL Customer Support for further analysis and resolution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.