3

we are using Web 8. While publishing items Pages and components are getting published successfully but categories stuck at Committing deployment or waiting for deployment stage.i m getting Object reference not set to an instance of an object error in TcmPublisher.Log

7/21/2016 10:41:45 PM <2060> Receiving deployment feedback for publish transaction [tcm:0-1446981-66560] with status: CommittingDeployment

7/21/2016 10:42:30 PM <2060> Transport service response: <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<TransportSummaries>
    <TransportSummary end="2016-07-22T01:42:21.887+03:00" referenceId="tcm:0-1446981-66560" start="2016-07-22T01:41:20.239+03:00" state="Success">
        <Processing>
            <Context topic="Content Delivery">
                <IsRollbackOnFailure>false</IsRollbackOnFailure>
            </Context>
            <Step end="2016-07-22T01:41:20.250+03:00" href="simple" type="Prepare transport" start="2016-07-22T01:41:20.239+03:00" state="Success">
                <RemoteEndpoint connector="DiscoveryService" end="2016-07-22T01:41:20.250+03:00" id="bRdHVRXIfODlWtOgbQ57lQ==" name="Discovery Service Upload" processor="10392@staging-web" start="2016-07-22T01:41:20.239+03:00" state="Success" windowSize="0"/>
            </Step>
            <Step end="2016-07-22T01:41:20.375+03:00" href="simple" type="Transporting" start="2016-07-22T01:41:20.257+03:00" state="Success">
                <RemoteEndpoint connector="DiscoveryService" end="2016-07-22T01:41:20.375+03:00" id="bRdHVRXIfODlWtOgbQ57lQ==" name="Discovery Service Upload" processor="10392@staging-web" start="2016-07-22T01:41:20.257+03:00" state="Success" windowSize="0"/>
            </Step>
            <Step end="2016-07-22T01:41:33.802+03:00" href="simple" type="Deployment preparation" start="2016-07-22T01:41:33.724+03:00" state="Success">
                <RemoteEndpoint connector="DiscoveryService" end="2016-07-22T01:41:33.802+03:00" id="bRdHVRXIfODlWtOgbQ57lQ==" name="Discovery Service Upload" processor="10392@staging-web" start="2016-07-22T01:41:33.724+03:00" state="Success" windowSize="0"/>
            </Step>
            <Step end="2016-07-22T01:41:39.552+03:00" href="simple" type="Deploying" start="2016-07-22T01:41:33.818+03:00" state="Success">
                <RemoteEndpoint connector="DiscoveryService" end="2016-07-22T01:41:39.552+03:00" id="bRdHVRXIfODlWtOgbQ57lQ==" name="Discovery Service Upload" processor="10392@staging-web" start="2016-07-22T01:41:33.818+03:00" state="Success" windowSize="0"/>
            </Step>
            <Step end="2016-07-22T01:42:21.887+03:00" href="simple" type="Deployment committing" start="2016-07-22T01:42:21.575+03:00" state="Success">
                <RemoteEndpoint connector="DiscoveryService" end="2016-07-22T01:42:21.887+03:00" id="bRdHVRXIfODlWtOgbQ57lQ==" name="Discovery Service Upload" processor="10392@staging-web" start="2016-07-22T01:42:21.575+03:00" state="Success" windowSize="0"/>
            </Step>
        </Processing>
    </TransportSummary>
</TransportSummaries>


7/21/2016 10:42:30 PM <2060> Receiving deployment feedback for publish transaction [tcm:0-1446981-66560] with status: Success

7/21/2016 10:42:30 PM <2060> Object reference not set to an instance of an object.
1
  • Did you try to open the transaction and check the stages that have cleared. I remember that in 2013 sp1, the transaction status in publishing queue will be stuck however when you open the transaction to view the details, it will have all stages as successful.
    – Hiren Kaku
    Jul 22 '16 at 2:12
2

There is some condition in event system code which was failing for category and causing publishing to fail after fixing the problem i m getting the success status.Thank you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.