4

We are currently upgrading a 2011 setup to web 8. At this moment we have troubles getting the XPM working. When we publish a page through the old publishing setup (deployers configured in CME) we get the XPM icon showing on that page. However when we publish that page through a target that is setup with the new Topology Manager setup, the icon just does no appear.

This is our current Topology Manager setup:

Topology Type

Name             EnvironmentPurposes     Id           ExtensionProperties
----             -------------------     --           -------------------
Staging Only     {Staging}               StagingOnly  {}                  

Cd Environment

EnvironmentPurpose   : Staging
DiscoveryEndpointUrl : http://<host>:8190/discovery.svc
Credentials          : "AuthenticationType":"Anonymous"
IsOffline            : False
ScopedRepositoryKeys : {}
Id                   : BestuurlijkeStaging
ExtensionProperties  : {}

Website

BaseUrls             : {http://<host>:8090}
CdEnvironmentId      : BestuurlijkeStaging
EnvironmentPurpose   : Staging
CdEnvironment        : 
ScopedRepositoryKeys : {}
Id                   : WebBestuurlijkeStaging
ExtensionProperties  : {}

WebApplication

ContextUrl           : /
WebsiteId            : WebBestuurlijkeStaging
EnvironmentPurpose   : Staging
CdEnvironment        : 
ScopedRepositoryKeys : {}
Id                   : WebBestuurlijkeStaging_RootWebApp
ExtensionProperties  : {}

Mapping

CmEnvironmentId     : trddev
PublicationId       : tcm:0-5-1
EnvironmentPurpose  : Staging
WebApplicationId    : WebBestuurlijkeStaging_RootWebApp
RelativeUrl         : /
PrimaryMappedUrl    : http://<host>:8090/
IsOffline           : False
CdEnvironment       : 
Id                  : Mapping1
ExtensionProperties : {}

Cm Environment

CoreServiceRootUrl     : http://<cmhost>/
WebsiteRootUrl         : http://<cmhost>/
CoreServiceCredentials : "AuthenticationType":"Windows", "UserName":"MTSUser", "Password":"********"
Id                     : trddev
ExtensionProperties    : {}

Discovery Service

If we call http://:8190/discovery.svc/Environment/PreviewWebServiceCapability results in following output

<?xml version="1.0" encoding="UTF-8"?>
  <entry xmlns:metadata="http://docs.oasis-open.org/odata/ns/metadata" xmlns:data="http://docs.oasis-open.org/odata/ns/data" xmlns="http://www.w3.org/2005/Atom" metadata:context="http://<host>:8190/discovery.svc/$metadata#Environment/PreviewWebServiceCapability" xml:base="http://<host>:8190/discovery.svc">
  <id>http://<host>:8190/discovery.svc/PreviewWebServiceCapabilities('DefaultPreviewWebService')</id>
  <title></title>
  <summary></summary>
  <updated>2016-07-26T13:06:32.032Z</updated>
  <author>
    <name>SDL OData v4 framework</name>
  </author>
  <link rel="edit" title="PreviewWebServiceCapability" href="PreviewWebServiceCapabilities('DefaultPreviewWebService')"></link>
  <link rel="http://docs.oasis-open.org/odata/ns/related/Environment" type="application/atom+xml;type=entry" title="Environment" href="PreviewWebServiceCapabilities('DefaultPreviewWebService')/Environment"</link>
  <link rel="http://docs.oasis-open.org/odata/ns/relatedlinks/Environment" type="application/xml" title="Environment" href="PreviewWebServiceCapabilities('DefaultPreviewWebService')/Environment/$ref"></link>
  <category scheme="http://docs.oasis-open.org/odata/ns/scheme" term="#Tridion.WebDelivery.Platform.PreviewWebServiceCapability"></category>
  <content type="application/xml">
    <metadata:properties>
      <data:id>DefaultPreviewWebService</data:id>
      <data:LastUpdateTime metadata:type="Int64">1469519953168</data:LastUpdateTime>
      <data:URI>http://<host>:8390/ws/preview.svc</data:URI>
      <data:ExtensionProperties metadata:type="#Collection(Tridion.WebDelivery.Platform.PreviewWebKeyValuePair)"></data:ExtensionProperties>
    </metadata:properties>
  </content>
</entry>

Business Process Type

Our business process type uses the StagingOnly TopologyType. The Resulted Target Out of that is Staging (XPM).

Anybody an idea what I am missing? i thougth that XPM would be enabled if the Discovery service of the Cd Environment had a PreviewWebServiceCapability.

Kr,

Thomas

2

So I found the cause, a rather simple one.

We did an upgrade from 2011 SP1 Hr2 with DB copy. This resulted in the Default Templates being those of 2011 SP1 Hr2. We therefore needed to upload the new Trdiion.SiteEdit.Templating.dll with TcmUploadAssembly.exe. This solved the issue for us.

1

Check whether your page source, whether do you have entry similar to as below:

<!-- Page Settings: {"PageID":"tcm:12-2705-64","PageModified":"2015-11-12T14:03:56","PageTemplateID":"tcm:12-33-128","PageTemplateModified":"2016-04-26T11:57:25"} -->
<script type="text/javascript" language="javascript" defer="defer" src="http://AXWEB8.ams.dev:80/WebUI/Editors/SiteEdit/Views/Bootstrap/Bootstrap.aspx?mode=js" id="tridion.siteedit"></script>

Most likely you may not have above entry as you are not getting XPM icon. If that is the case check the following:

Prior to web 8 we used to mention the site edit url on the XPM TBB in page template, but from Web 8 we do not mention this url in new XPM TBB. Hence make sure that you have re-imported fresh XPM TBB's for web 8 via template builder and then also make sure to have session enable content web service.

Prior to Web 8:

  <Template xlink:href="tcm:1-39-2048" xmlns:xlink="http://www.w3.org/1999/xlink" xlink:title="Enable inline editing for Page" />
    <TemplateParameters>
      <Parameters xmlns="uuid:F846A60E-96ED-4D37-A5C7-17ED8E9EDC43">
        <SiteEditURL>http://localhost/WebUI/Editors/SiteEdit/</SiteEditURL>
      </Parameters>
    </TemplateParameters>

After Web 8:

 <Template xlink:href="tcm:1-39-2048" xmlns:xlink="http://www.w3.org/1999/xlink" xlink:title="Enable inline editing for Page" />
    <TemplateParameters>
      <Parameters xmlns="uuid:F846A60E-96ED-4D37-A5C7-17ED8E9EDC43" />
    </TemplateParameters>

Hope this helps!

  • Thanks it was not the real cause but it helped finding it! – Thomas Hendrickx Jul 28 '16 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.