2

Using 2013 SP1, publishing to Broker DB and file system.

Whenever a specific component is published, it stays in "Committing Deployment" phase and never succeeds in the publishing queue. Even after few tries, the issue continues. After few number of tries, deployer doesn't handle any more item and we see "Throttled" status in the queue. It then requires deployer restart. This component is not placed on any page and has got only one component presentation. Custom metadata is included in the component presentation output. 3 images are impilcitely published with this component.

As wecan see in the deployer logfile, this specific transaction doesn't have any record after logging "Precommit" phase. Last info that we see is "PreCommitPhase - Executing workers for transaction: tcm:0-11272601-66560 with 19 Workers". For successfully published items, we see more records in the deployer log after this step. We are wondering whether the deployer never comes out of handling this item and when the same item is published few times, all threads are into the same issue which then causes the deployer to say "Throttled".

Interestingly the same version of the component was earlier published successfully.

What is the root cause of this issue and how can it be fixed?

1

For the transaction having issue, verify the entire log not just the place where it was blocked. I had faced similar issue in which there was primary key issue for insert.

This situation arise if by any chance the database become inconsistent in terms of data and easiest quick fix is to un-publish the component and then publish it again.

  • Interestingly unpublishing of this component also stays in "Committing deployment" phase. – premkumar subramanian Aug 1 '16 at 12:04
  • Do you have any event system or deployer extension implementation that runs during committing deployment phase, check it, there might be some issue with that code. – Hiren Kaku Aug 1 '16 at 13:57
1

There's a few thing I would verify:

  • Make sure regular maintenance of the database is done (reindex, etc...)
  • Make sure broker DB version is same version as the tridion jar/dll/config you are using
  • If you are seeing throttling, check on deployer server utilization. Maybe even increase the worker size of cd_deployer_conf.xml
  • Throttling issue could be caused by old transaction files in /temp and /bin/transaction folder on publisher server (do a cleanup here and restart the transport/publisher service)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.