1

We are facing issue with creating page with Page type in experience manager with version SDL web 8.1.1 DXA Java 1.4.

When we create new page using page type, page created in CMS and auto Publish to Staging target.

But Once page created it throw 404, When we restarted tomcat (Where CDA application hosted) page appear fine. We are not sure why we want to restart tomcat when we create simple page, Moreover when we create normal page in CMS UI, we need not to restart tomcat.

Moreover We go ahead and host application on 2 different developer machine on Tomcat, both pointing to same discovery service.

And then create Page using page type on first developer machine, page created in CMS and also Published, but on First developer machine page throw 404 error and at the same time on second developer machine same page appear fine.

There is no error log created any where for this issue on first developer machine where page created using page type.

Moreover calling same discovery service with .Net DXA 1.4 (demo site) everything works fine.

I found on Tridion documents they talked about the similar issue and ask to apply "Cumulative Update 1 for SDL Web 8".

Not sure where is the problem. Please help.

Thanks Piyush Jain

  • What you describe sounds like a problem with XPM Session Preview. Can you verify whether XPM Session Preview works properly in other scenarios? For example, open an existing Page in XPM, change some content (in XPM) and press the "Update Preview" button. If your changes disappear, XPM Session Preview doesn't work. – Rick Pannekoek Aug 4 '16 at 16:20
  • @Rick: Preview service is working fine on 8083 port as with .Net dxa 1.4 demo site everything works fine, we are only facing issue with Java DXA 1.4 hosted on tomcat. – Piyush Jain Aug 5 '16 at 9:18
  • OK, then it could be a caching issue. Try setting the cache TTL for CIL (cd_client_conf.xml) and DD4T (ehcache.xml) to low values (1s). – Rick Pannekoek Aug 5 '16 at 10:33
  • We have to disable ehcache in tomcat file " startup.bat" file by adding parameter "startup.bat-Dnet.sf.ecache.disabled=true", Then page start working, but still at first time page throw 404 error and later we need to refresh again then page start appear...Do you think that we have to disable ehcache at tomcat level and also why it is throwing 404 at first time. – Piyush Jain Aug 11 '16 at 10:07
1

Multiple network cards? Try to force the RMI to pick up a specific IP address. The deployers, CCS and the websites reside on different servers? at least set the deployer and CCS on the same server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.