We are not able to find any settings by which we can disable XPM from content published only to Live target, We are using SDL web 8.1.1 + DXA 1.4 default templates to render pages and components.

Moreover we have setup targets staging/live using Business Type and using topology manager.

Please help.

Thanks Piyush Jain

  • 4
    XPM will be enabled if the target you're publishing to has the capabilities needed. This is done by the Topology Manager "asking" the discovery service if the current target supports it. In other words, if you don't have the XPM related capabilities in Live (Session Preview Service, Session-Enabled content service) then you will not have XPM in that target.
    – Nuno Linhares
    Commented Sep 1, 2016 at 17:07

1 Answer 1


As Nuno mentioned, SDL Web 8 in general uses the presence of the Preview Service Capability in the CD Environment (Discovery Service) to determine if it is XPM-enabled or not.

DXA automatically suppresses XPM markup on a CD Environment which is not XPM-enabled (i.e. has no Preview Service Capability).

  • We have removed the preview capability configured in discovery service and register discovery service again, But still XPM button and in page source XPM tags are appearing on Live target site. Please confirm if we need to do any additional settings to make it work. Commented Sep 2, 2016 at 12:26
  • How did you "register discovery service again"? Did you get a confirmation that the Preview Capability was removed? Commented Sep 2, 2016 at 13:42
  • 1
    This is Resolved now, Earlier we are updating discovery registration with command "Java -jar discovery-registration.jar update ", But if we want to remove any existing capability then we we should use command "Java -jar discovery-registration.jar forceSync" instead. Thanks Rick Commented Sep 5, 2016 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.