3

When sending jobs for translations, we are getting "The Translation Job does not contain any translatable items." I am very sure there are elements to translate and it is marked "Translatable" in the schema. It appears this issue only happens for a particular schema. We are not sure what else to check, anybody has encountered this before?

  • If you create new content on the 'accused' schema does this translate (the first time)? - The Translation Manager Plugin will check if the source has changed since the last translation took place - and if not - exclude from the list of items to translate - following the instructions from Robert would fix this. Other 'standard' checks would be to ensure the field is marked correctly in the schema and that the publication is set as a translation target. – Dylan .. Mark Saunders Sep 12 '16 at 22:37
  • I tried to create new content, it doesn't work. I verified the schema as well. I even created a new one, but still doesn't work. – charles Sep 13 '16 at 17:14
  • Can you include screenshots of the publication target and source configuration? – Dylan .. Mark Saunders Sep 13 '16 at 20:22
3

In the Publication Properties (Translation tab), can you

1) confirm you see the "source Publication" in the target config

From source

and

2) the "target Publication" in the source config

From target

Also, when you select "Translate" on a Component (or a Bundle?)

3) do you see the same as here:

  • Sending from the SOURCE Publication

image 1 - from source

  • Sending from the TARGET Publication

image 2 - from target

4) .. is the schema checked in properly (I've banged my head against a wall with "config settings" in a schema to later find the schema 'in use' was the previous version until I explicitly checked in it!!)

Is the content you are sending

5) created in the source Publication

6) localized or not in the target Publication

| improve this answer | |
  • Thanks for the detailed answer. The translation generally works fine. It is just for one particular component. We have found our the issue. Will update it here as an answer. – charles Sep 26 '16 at 20:40
2

I have encountered this issue before. Before you send to translation, make sure the "Include already translated items" checkbox is checked should fix it

| improve this answer | |
  • Thanks for the answer. I already tried that. It doesn't work. – charles Sep 13 '16 at 17:12
  • Do you have embeddable schemas and are those fields translatable? – Robert Jin Sep 13 '16 at 19:26
0

We find our the root cause of the issue. It seems Tridion is not including the nested component when sending for translations. We will have to send the nested component separately (We are using Tridion 2011 SP1). It seems we need to do some customization of the Tridion or TMS system for it to include nested component.

| improve this answer | |
  • WHen you say Nested Component - do you mean a linked component? I've seen issues with embedded schemas in the past but this content is part of the core component and can't be 'send serparately' – Dylan .. Mark Saunders Sep 26 '16 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.