3

I'm really stuck trying to connect to the stream upload service via coreservice - Over HTTPS

I'm getting the following error:

The provided URI scheme 'https' is invalid; expected 'http'

I can connect to the usual content endpoint (wsHttp_201501) the issue i'm having is connecting to the upload service (streamUpload_basicHttp_201501)

Here's my config file:

<protocolMapping>

  <add scheme="https" binding="wsHttpBinding"/>

</protocolMapping>


<bindings>

  <basicHttpBinding>

    <binding name="basicHttp" maxReceivedMessageSize="10485760">

      <readerQuotas maxStringContentLength="10485760" maxArrayLength="10485760" />

      <security mode="TransportCredentialOnly">

        <message clientCredentialType="UserName"/>

      </security>

    </binding>

    <binding name="streamDownload_basicHttp" maxReceivedMessageSize="209715200" transferMode="StreamedResponse" messageEncoding="Mtom" sendTimeout="00:10:00">

      <security mode="TransportCredentialOnly">

        <message clientCredentialType="UserName"/>

      </security>

    </binding>

    <binding name="streamUpload_basicHttp" maxReceivedMessageSize="209715200" transferMode="StreamedRequest" messageEncoding="Mtom" receiveTimeout="00:10:00">

      <security mode="TransportCredentialOnly">

        <message clientCredentialType="UserName"/>

      </security>

    </binding>

  </basicHttpBinding>



  <wsHttpBinding>

    <binding name="wsHttp" transactionFlow="true" maxReceivedMessageSize="10485760">

      <readerQuotas maxStringContentLength="10485760" maxArrayLength="10485760"/>

      <security mode="TransportWithMessageCredential">

        <message clientCredentialType="UserName"/>

      </security>

    </binding>

  </wsHttpBinding>



</bindings>

<client>

  <endpoint name="wsHttp_201501" address="https://serv_name.com/webservices/CoreService201501.svc/wsHttp" binding="wsHttpBinding" bindingConfiguration="wsHttp" contract="Tridion.ContentManager.CoreService.Client.ISessionAwareCoreService">

    <identity>

      <dns value="serv_name.com/" />

    </identity>

  </endpoint>

  <endpoint name="streamUpload_basicHttp_201501" address="https://serv_name.com/webservices/CoreService201501.svc/streamUpload_basicHttp" binding="basicHttpBinding" bindingConfiguration="streamUpload_basicHttp" contract="Tridion.ContentManager.CoreService.Client.IStreamUpload">

    <identity>

      <dns value="serv_name.com/" />

    </identity>

  </endpoint>        

</client>

2

For HTTPS, the WCF binding security mode should be set to Transport instead of TransportCredentialOnly

| improve this answer | |
  • Afraid this has no impact - still the same error. – johnwinter Sep 22 '16 at 16:26
  • 1
    Did you change both client and server configs? – Rick Pannekoek Sep 23 '16 at 14:18
  • Guess this is fixed with setting up right contract filter in stream_upload_basichttp and using latest 8.2 core service dll. – Vikas Kumar Oct 3 '16 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.