4

I am creating the localization sites /en using the Set-TtmMapping -RelativeUrl but getting the error. Any Suggestion would be highly appreciated.

And When trying to update the publication URL from CMS gets error

(80040301) Unable to save item

Invalid value for property 'PublicationUrl'. The Publication URL '/en' of the Publication with ID 'tcm:0-1010-1' does not match the server-relative URL '' of the Mapping with ID 'Website6'.

PS C:\Users\mtsuser> Get-TtmMapping


CmEnvironmentId     : Tridioncm_1921681216
PublicationId       : tcm:0-1010-1
EnvironmentPurpose  : Staging
WebApplicationId    : Website6_RootWebApp
RelativeUrl         : /
PrimaryMappedUrl    : http://dxa.com/
IsOffline           : False
CdEnvironment       : 
Id                  : Website6
ExtensionProperties : {}


PS C:\Users\mtsuser> Set-TtmMapping -RelativeUrl en
cmdlet Set-TtmMapping at command pipeline position 1
Supply values for the following parameters:
(Type !? for Help.)
Id: Website6
Set-TtmMapping : The server-relative URL '/en' of the Mapping does not match the Publication URL property '/' of the Publication 'tcm:0-1010-1'.
At line:1 char:1
+ Set-TtmMapping -RelativeUrl en
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Tridion.Topolog...tMappingCommand:SetMappingCommand) [Set-TtmMapping], DataServiceException
    + FullyQualifiedErrorId : Tridion.TopologyManager.Automation.Cmdlets.SetMappingCommand
6

Just set the Publication URL (in CM) to empty. That makes it "context-relative" instead of server-relative, meaning that there is no longer an overlap between the part of the URL managed in Topology Manager and in Content Manager.

Likewise, the "Multimedia URL" should be changed to be context-relative by ensuring it does not start with a slash (and it does not contain the RelativeUrl of the TTM Mapping).

|improve this answer|||||
  • Also you have option to mention your "RelativeUrl (URL path segment) in your Publishing property of Publication. – Vikas Kumar Oct 3 '16 at 19:17
  • @rick Thanks for the suggestion issue is resolved – Hem Kant Oct 6 '16 at 9:38
0

I hope below document will help you to setup multilingual Web site,

Configuring the Web application for multilingual Web sites

|improve this answer|||||
  • It's okay to link to a site, but remember that a lot of links end up dying. So it's better to copy the relevant bits into your answer (so the information is always available) and you can leave the link for additional information only. – Peter Kjaer Oct 7 '16 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.