3

When content porting is attempted to export the structure group from 2013 sp1 hr1 to import into web 8 environment then content porting fails with the error:

"Invalid value for property 'DefaultPageTemplate'. Default PageTemplate property must not be set if IsDefaultPageTemplateInherited property is true"

How can I resolve this issue?

2

Strangely enough we had this today on 2011.

In our case, the root SG was inherited from 000 Empty Parent in the web publication and using Default Page Template. However, in the source CME it had been localised and was using a different PT.

Localising the SG in the target CME resolved the issue for us. I'm not sure why Content Porter didn't do it for us though!

| improve this answer | |
  • Seems to be good suggestion however in our case source environment is 2013 sp1 with same setting for Empty parent for using Default page template and same is being ported to web 8 environment and it is failing. No localization at any place. – Hiren Kaku Oct 3 '16 at 22:42
0

My bad, ignore ECL point.

Now please see if your SG has Default Page Template checked out again to false and checked in again to choose fresh default PT. Save and close and that Should help. Exception clearly says you already have Default Page Template set and it's not inherenting.

| improve this answer | |
  • How does ECL impact the content porting that is also defaultpagetemplate? Also, while content porting, explicitly unchecked external content library checkbox so how does it come into the picture? – Hiren Kaku Oct 3 '16 at 20:36
  • what you interpreted from error is correct however source environment 2013 sp1 has the same setup and it is working fine and we are able to content port. So what has changed for the destination environment which is web 8, content porter or the way data is stored. Either case, content porter is not able to handle the data it seems. – Hiren Kaku Oct 4 '16 at 0:13
  • Suggestion given by Dave Forber above is also a way to fix it, I had encountered this issue once. – Vikas Kumar Oct 4 '16 at 18:41
  • Already tried that suggestion however it did not working, so created support ticket. – Hiren Kaku Oct 4 '16 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.