Tridion 2013 CME has stopped loading and throws an "invalid license" error. We have already confirmed with SDL that the licenses are good and they even provided temporary license files which didnt help resolve the issue as well.

Another thing that we noticed is that the Tridion MMC snap in is not properly as well. It throws error :

"Could not read configuration item. Modification of this item is not available on this machine. Automation error, the specified module could not be found".

When we click on "general settings", the error is a little different :

"Error while getting security setting.Automation error, the specified module could not be found"

This happened on 3 servers and the only common change on all the 3 servers was the patching done. We have already verified that java/.net framework versions were not affected by patching.

Any suggestions?

  • the only time I've seen this error is when the .Net Framework version was, indeed, updated. Can you confirm the patching that was done if it's not commercially sensitive? Oct 18, 2016 at 20:24
  • Have you tried doing a "repair" using the Content Manager installer? Also, are you on the latest hotfix rollup?
    – Robert Jin
    Oct 18, 2016 at 20:50
  • @Robert: Yes we tried "repair" and it didn't work.
    – GJin
    Oct 18, 2016 at 21:04
  • @Dylan: I agree and that was one of the first things that we checked but its confirmed. .net Framework was not updated. I am not sure i understand "commercially sensitive".
    – GJin
    Oct 18, 2016 at 21:04
  • have you tried a repair or reinstallation of .net framework via the command line in administrator mode?
    – Robert Jin
    Oct 18, 2016 at 21:11

2 Answers 2


So finally, we got the answer for the problem. It looks like msxml.dll was removed as a part of some vulnerability remediation by our hardware maintenance team!! We reverted the change and got the systems working again. Thanks all for the timely comments and anyone who faces the problem : Check with your server team first for ANY kind of changes made.


I am not sure about the license error however given below are the details for resolving snap in issue.

The Content Manager uses a .NET encryption key to ensure the encryption of sensitive configuration data such as passwords. By default nothing is encrypted. The following user accounts automatically have access to this encryption key:

  • Any Content Manager system account (including the Content Manager user account and impersonation user accounts created during installation)
  • The user account of the user who originally ran the installer

If you want to run the Snap-in and/or Windows services as another user than specified, you must grant that new user access to the encryption key. To grant this access, log on as the user account of the user who originally ran the installer, or as another, similarly authorized user with access to the encryption key, and do the following:

  • Open a Windows command prompt.
  • Go to a directory on your machine on which a version of the .NET Framework is installed (a subdirectory of C:\Windows\Microsoft.NET\Framework\ or C:\Windows\Microsoft.NET\Framework64)
  • Enter the following command: aspnet_regiis -pa "TridionRsaKeyContainer" "\" where is the domain of this user and is the username of the user.
  • Yeah, i am aware of this but this is not our case. We are using the same ID that was used to install the CMS. The error that you get when the access is denied is a different error and not the one that we are getting. Actually, After we click on "ok" we are able to see a few properties like "search settings" etc but not able to see few like "directory services" etc
    – GJin
    Oct 18, 2016 at 18:01
  • Still, try to run the command as administrator for the user and see if it resolves
    – Hiren Kaku
    Oct 18, 2016 at 18:29
  • Ok did that, but still the same error. "Could not read configuration item. Modification of this item is not available on this machine. Automation error, the specified module could not be found".
    – GJin
    Oct 18, 2016 at 18:36
  • @Hiren - I think your answer relates to the more specific case when the user is presented with "Account has no permission to access the protected configuration section 'tridion.security'. Contact your system administrator." Oct 18, 2016 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.