3

I’m testing DXA 1.5 (Java) on Web 8.1.1, have published 400 Example Site successfully to broker db and dropped war file to Tomcat webapps directory. When I browse to root URL at http://localhost:8080, I see error "http status 404 -localization not found". any idea why?
enter image description here I have checked that publication components/pages are same as a working DXA website, and see that the _all.json file is resident in the broker BINARYVARIANTS table (issue seems somewhat similar to below forum thread). ERROR : _all.json' not found for Localization | DXA 1.4 .NET web 8.1.1

Additional details:

  • When appending admin/refresh to the root URL, error message is similar although an exclamation mark is appended to messsage and title (Localization not found!)
  • BaseUrls param output for Get-TtmWebsite is http://localhost:8080
  • CD microservices running as below, and I have verified the endpoints can be browsed to (note the Session Preview Content Service has not yet been installed).
    1. Content service
    2. Deployer service
    3. Discovery service
    4. Context service
  • It has been suggested to me that the error would be related to cd_dynamic_conf.xml, insofar as the publication ID is not matched to the id in the page.
6

You are requesting http://10.9.5.175:8080

You have your BaseUrls set as http://localhost:8080

Add a Base URL of http://10.9.5.175:8080

You can add a BaseURL with the Powershell command (assuming your Website Id is 'Website1' and you want to keep localhost)

Set-TtmWebsite -BaseUrls "http://localhost:8080", "http://10.9.5.175:8080" -Id Website1

You can then check you're BaseUrl is active by viewing the data from the Discovery Service at http://URL:PORT/discovery.svc/WebApplications (default port: 8082), where you should see output like:

<content type="application/xml">
   <metadata:properties>
      <data:id>Website1_RootWebApp</data:id>
      <data:ContextURL>/</data:ContextURL>
      <data:BaseURLs metadata:type="#Collection(Tridion.WebDelivery.Platform.BaseURL)">
         <metadata:element>
            <data:Protocol>http</data:Protocol>
            <data:Host>10.9.5.175</data:Host>
            <data:Port metadata:type="Int32">8080</data:Port>
         </metadata:element>
         <metadata:element>
            <data:Protocol>http</data:Protocol>
            <data:Host>localhost</data:Host>
            <data:Port metadata:type="Int32">8080</data:Port>
         </metadata:element>
      </data:BaseURLs>
   <data:ExtensionProperties metadata:type="#Collection(Tridion.WebDelivery.Platform.WebKeyValuePair)" />
   </metadata:properties>
</content>
  • 1
    Note that checking the Discovery Service using a browser only works if your CD Environment is configured to have OAuth disabled. If OAuth is enabled, you will need more advanced tools which allow you to obtain and specify an OAuth bearer token. – Rick Pannekoek Oct 26 '16 at 14:16
  • @chris-morgan's answer worked, thanks. – Terry Kim Oct 26 '16 at 16:40
  • Please accept the answer if it worked for you :) – Chris Morgan Oct 27 '16 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.