0

I am getting below Message at the last step of Installation UI window "Failed to Install product. Failed to install prerequisite 'Windows Features and Roles'. Please try to install prerequisite manually."

Below Listed Windows Features it failed to installed as part of Installation: enter image description here

Manuall Installation of these pre-requisite Windows Feature also FAILED in powershell with reason being these are Invalid Feature Names enter image description here

5
  • 3
    i don't see logs, make sure internet access is there on server to install the prerequisite .
    – Raj Kumar
    Nov 10 '16 at 13:18
  • 1
    +1 to Raj's comment. The installer will tell windows to install these pre-requisites, which in turn triggers windows to fetch updates from the Internet. If your server can't access the sites where this is hosted, it won't install them... Alternatively, you can install these yourself, then run the installer.
    – Nuno Linhares
    Nov 10 '16 at 13:58
  • Hi Raj,Nuno ;Thanks for sharing comments.The server has internet access and then also its getting failed. For 2nd option to install them manually I tried and found these listed windows features are not part of .Net Framework 4.5 (recommended for SDL web8). Do I need to install .Net Framework 3.5 to fix this issue please suggest Nov 10 '16 at 14:24
  • To add on the above comment, The Failed Pre-requisite Features are not in the list of available windows features on CMS server. List displayed on PowerShell using command : Get-WindowsFeature Nov 10 '16 at 14:38
  • screenshot added for Manual install of Features that FAILED; thanks Nov 10 '16 at 15:09
1

I'd check a few things:

  1. Check the specific version of Windows Server 2012 R2 you are running? Perhaps you are using a specialized version, like Hyper-V or Essentials?
  2. Does the server have free access to the internet. I've seen similar issues when the server requires a proxy to access the internet, and it failed to install .Net 3.5 (dependency of IIS)
  3. Use the Powershell command Get-WindowsFeature to see if IIS-ASPNET is called something else on your machine, for some reason. Not a solution but it might get you to the next step of problem solving
  4. If possible, perform a clean install of the OS as see if the problem re-occurs
0

Try going into the Server Manager > Server Roles and install the Application Server and Web Server (IIS) via the gui. After this is installed, SDL installer should be able to install the rest of the prereqs

Please review the checklist and make sure you fulfill everything here:

https://docs.sdl.com/LiveContent/web/content.xql?pub=SDL%20Web-v1&lang=en-US&action=topic&xslmode=print&docid=GUID-A6CBE401-9EB7-4534-9362-4B15B19B290E

0

The Solution was to disable/edit the Group Policy that was restricting the script to perform download operation from Microsoft site. The Infra team did that group policy change and after that it worked fine and able to enable the required windows features on the server machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.