3

When I execute "Upgrade Content Manager database.ps1" script on powershell I got the message "Database is up to date or has invalid version". Same is the outcome for "Upgrade Topology Manager database.ps1". But "Upgrade Content Data Store.ps1" script for upgrading Tridon_Broker and XPM_database worked perfectly fine. I checked the table TDS_DB_INFO and it shows the db_version not updated for content manager and Topology manager database.

TDS_DB_INFO :Content Manager Database,Topology Manger Database DB_VERSION = 8.1.0.0

TDS_DB_INFO: Tridion Broker Database,XPM Database DB_VERSION = 8.1.1.0

enter image description here

4

The upgrade scripts provided for content manager database is for upgrading from 2013 sp1.

There is no change between content manager databases for 8.1.0 and 8.1.1. That's why there is no need for upgrade script and giving you message for invalid version as it is expecting 2013 version for database.

| improve this answer | |
  • your first statement is correct, but second that its expecting 2013 is partially correct as 8.0 -> 8.1 CM updates also possible. – Raj Kumar Nov 15 '16 at 9:54
  • @RajKumar 8.0 was an SDL Cloud only release. 8.1 was the first available on-premise release, so there are no 8.0 > 8.1 updates/scripts, only 2013 > 8.1 – David Forster Nov 15 '16 at 11:37
  • @DavidForster scripts exists in the database. so are those for cloud version only "Upgrade Content Manager database_80_81.sql"? – Raj Kumar Nov 15 '16 at 11:49
  • @RajKumar Sort of. At some point the team will have written the upgrade from 2013.x to 8.0, and then from 8.0 to 8.1. They won't have combined them... the upgrade script will simply execute them both. – David Forster Nov 15 '16 at 12:02
0

Hiren seems right as there is no CMS powershell script available in the DB scripts but scirpts for Content DB and UGC exists. check followign screen shot.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.