4

Environment Used: SDL web 8+ Linux+ DXA 1.4

We are facing issue while we configure content(Session enabled) service into load balancer using NGINX.

Content service using load balancer IP is working fine, but when we registered this load balancer content service IP to discovery service, web site throwing “null pointer exception”,

But if we configure/register content service URL with actual server IP, Website works fine.

Please help if you see any such issue, and let me know if I missed anything while configuring content service with load balancer IP.

Content Service response with load Balancer server IP as as below:(For testing we only configure one server IP to NGINX)

enter image description here

1

Can they try installing the service-container-filter-8.x.y-z.jar which is included in the distribution within resources\filter? This filter forwards some requests that some load balancers add back to the service (such as Amazon's ELB).

To install in one of the microservices:

  1. Copy JAR to appropriate <service_name>/lib folder
  2. Reinstall service
  • I have tried this, but still the same issue. – Piyush Jain Jan 11 '17 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.