Unable to search and users from Active Directory on SDL Web8.

Getting this Error Message:

Unable to list users from "XXXX DOMAIN" This request operation sent to net.tcp://localhost:2660/CoreService/201501/netTcp did not receive a reply within the configured timeout (00:01:00). The time allotted to this operation may have been a portion of a longer timeout. This may be because the

I'd verified by telnet this service is up and running by telnet command

Any help would be highly appreciated

2 Answers 2


Have you researched / tried increasing the timeout?

You're probably hitting a limit on the Active Server directory rather than in Tridion (increasing the Tridion timeout to something large would show this). You could check this in the logs of the AD server.

Have you tried executing a similar query directly using something other than Tridion and seeing if you get the same result?

If you're just trying to add users then pre-Web8 there was a GUI extension created to work-around getting the Domain list (which can be very large and timely to receive) - where you as admin would simply add the domain and the username and it would be added directly (through the GUI/API) without the look-up.


Yes. It's fixed by increasing the timeout value from 1 to 5 on this path TRIDION_HOME\SDL Web\web\Web.config

<!-- sendTimeout is about the entire operation, incl. traffic. Default: 1 min. -->
        <binding name="CoreService_netTcpBinding" transactionFlow="true" transactionProtocol="OleTransactions" maxReceivedMessageSize="2147483647" sendTimeout="00:05:00">
          <readerQuotas maxStringContentLength="2147483647" maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxDepth="32" maxNameTableCharCount="81920" />
  • 100000 active users in my domain list, any suggestion for web.config configuration setup? Commented Feb 2, 2017 at 23:23
  • @Sudhakar: Not sure but still recommend try to keep the higher number value until you get success from the timeout. try to test how fast this active directory listing on the inside of the server with folder permissions
    – Velmurugan
    Commented Feb 7, 2017 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.