5

I imported DXA 1.6 into SDL Web 8.
But publishing failed at phase 2- transporting.
The error message is below:

Transport failed: Could not transport tcm:xxx-xxx-xxx.Content.zip using HTTPS, cause: Unauthorizaed.

I guess this has relation with the DXA CD Environment because when I ran ttm-prepare.ps1, I left the Client ID and Secret blank. So the Environment created is like below (AuthenticationType is "Anonymous"):
enter image description here
Then I tried to set the Authentication type to OAuth with Client ID "cmuser" & its password.
But this failed with an error message. Please refer to the picture below, and I translate Japanese part into English. enter image description here

'CDEnvironment2' could not be saved. Authentication failed while trying to communicate with service "http://localhost:8092/discovery.svc" which is detected by CD. Failed to authenticate with the token provider.

Additional information maybe useful:
I have a discovery service which uses port 8082 and token service's url localhost:8082/token.svc
The discovery used by DXA Environment uses port 8092 and the same token service's url as above. Is this the problem?
Thanks in advance.

More Information

I have tried to modified the token's url of DXA discovery service (whose port is 8092). Now the token service's url is localhost:8092/token.svc rather than localhost:8082/token.svc

UPDATE

enter image description here

This picture shows what I want.
I checked each new created service and found that they were linked with the existing discovery service, not the new created service.
Then I correct the dependency between them. (New created services are made to link with new created discovery service.)
However, even though my publishing DXA page failed. The error message showed that "Unable to establish transport to destination.".
enter image description here
I also could not set the Authentication type to OAuth with Client ID "cmuser" & its password of DXA CD Environment.
Any idea?
Thanks in advance.

  • How are the actual microservices configured, with or without OAuth security? – Bart Koopman Dec 1 '16 at 10:57
  • I only changed the port number, the name & database information when installing service. I checked that the OAuth security is true in ambient.xml of discovery service. – Heimei Dec 2 '16 at 0:04
  • Can you explain what changes you did here as the Oauth is disabled. Should we update all cd_storage_conf.xml files of the microservices with cmuser instead of registration? – Developer Feb 7 at 20:13
3

I solved this problem. First set the value of "Security OAuth Enabled" to false. Then set the CD Environment Authentication Type with cmuser. Restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.