4

The error in my browser console

My CME is not loading correctly in Firefox, when I followed these steps:

  1. Clear all history/cache and close Firefox. Image showing how the history and cache is cleared

  2. Open the Content Manager Explorer (SDL Web 8)

  3. The CME fails to load and just shows a blank screen (see screenshot below) Image showing the broken CME

It does load properly if I press F5 again afterwards.

What can I do to fix this? Are there any additional settings to configure in Firefox?

4
  • Check the console, are there any errors?
    – Hiren Kaku
    Dec 8, 2016 at 19:47
  • no error in console. please refer attached console screen shot. Dec 8, 2016 at 19:50
  • I've edited this question too, so it is more readable. Including formatting it correctly. Please make a little more effort to format, spell-check, and phrase your question in a way that makes it easy to read and answer. Thanks! Dec 9, 2016 at 9:31
  • So the issue is related to an extension?
    – Nuno Linhares
    Dec 13, 2016 at 1:19

3 Answers 3

0

It seems to me that this error might come from a GUI extension. Since it apparently only occurs when you clear your cache in Firefox, it seems like a classic timing issue (the script tries to access stuff before it is available).

If it isn't obvious which extension causes this, I would start disabling them one by one until you cannot reproduce it anymore. Then report the issue to the author of the extension.

(If I'm wrong and this is actually not in an extension, simply report the issue to SDL Customer Support instead)

0
0

Presumably this is the extension (or some variant of) noted in snipt:

Are you calling this function before some dependency such as the user (see var settings = this.getUserSettings(); ) or before the function itself is even available?

I would locate where you are calling this (1) and then do some standard GUI debugging to provide us with more details to help get to the root cause.

(1) maybe switch compacting of JS off and search through for reference to this function and deduce which extension is trying to use it

0

Final I found the issue in tridion namespace and updated the new namespace, its working fine now.

OLD Namespace: Tridion.Web.UI.Editors.CME.commands)

NEW Namespace:SDL.Web.UI.Editors.CME.CommandSets.All)

2
  • In which file did you change it? Dec 13, 2016 at 6:14
  • i updated in editor.config file. Dec 13, 2016 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.