3

I am executing a heavy query on a Tridion 2011 SP1 system via the core service via http. After a minute, I get the following message:

Exception calling "GetListXml" with "2" argument(s): The request channel timed out while waiting for a reply after 00:00:59:9730000. Increase the timeout value passed to the call to Request, or increase the SendTimeout value on the binding. The time allotted to this operation may have been a portion of a longer timeout."

When I look in WebUI/WebRoot/Web.config, I can see in the configuration/system.serviceModel/bindings/webHttpBinding/binding that sendTimeout="00:05:00"

This makes me wonder whether I'm looking at the right timeout setting - as the times don't match, presumably not, I suppose. Where else should I be looking for a timeout? Are there any known timeouts that default to 60 seconds?

6

Have you tried increasing the SendTimeout of your local (client side) binding, rather than the setting you found on the server? Default is 1 minute, which would seem to match your exception. Code & XML config examples available here.

| improve this answer | |
  • 1
    Thanks David. Indeed it was on the client. Luckily this setting is supported in the Tridion-CoreService powershell module. You can modify it with Set-TridionCoreServiceSettings -ConnectionSendTimeout "00:05:00" or similar – Dominic Cronin Dec 21 '16 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.