2

We recently migrated our production environment to SDL Web8. Post this migration, few content authors are facing issue with binary component creation. Below error message is shown when the author attempts to load the image in the component.

The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '00:01:00'.

Few of those users are admins too.

Appreciate your help on this.enter image description here

2

Typically this issue is seen when the WCF/Core service timeouts and message size(s) exceed defaults. Pay attention especially to the sendTimeout, receiveTimeout, openTimeout and closeTimeout values, plus all size related attributes such as maxBufferSize, maxReceivedMessageSize, maxBufferPoolSize and readerQuotas values in the TcmServiceHost.exe.config file.

Note if these values are not explicitly set they will default to smaller values such as 10 min for timeouts for instance and 64K for maxBufferSize. The maxBufferSize also comes into play when sending current user information because this is stored in the AccessTokenData - passed from the client to the service in the header of the upload request. Such data can be seen with Fiddler. This header is placed in buffer by WCF while the binary file stream gets uploaded. If the user has a large group membership, this value will quite likely need to be raised.

These two posts cover most of these settings and a few more:

  1. https://stackoverflow.com/questions/9508729/sdl-tridion-times-out-when-publishing-multiple-items/14386099#14386099
  2. SDL Tridion timeouts when publishing multiple items
  • Thanks Elena. "This header is placed in buffer by WCF while the binary file stream gets uploaded." Was it happening in SDL Tridion 2013 SP1 too or is it something introduced in SDL Web 8? – Mustafa Jan 11 '17 at 13:50
1

The workaround is to increase buffer size limit. This can be done in TcmServiceHost.exe.config, you need to add a maxBufferSize parameter (it is set to 500KB here):

<binding name="StreamUpload_netTcpBinding" maxBufferSize="524288" maxReceivedMessageSize="2147483647" transferMode="StreamedRequest" receiveTimeout="00:30:00" />

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.