0

I am trying to install module “SDL DXA ExperienceOptimization Module 1.7” (Downloaded from SDL Community site) On top of existing SDL web 8 CMS. I am getting below error.

enter image description here

Please help to resolve this issue.

Thanks Piyush Jain

  • Which version of DXA are you using? 1.4 or 1.7? Or are you trying to combine DXA 1.7 XO Module with DXA 1.4 Framework. Note that such version combinations are not tested and not guaranteed to work. – Rick Pannekoek Jan 4 '17 at 13:16
3

According to the error message, you don't have Experience Optimization TBBs in your CMS.

You must ensure that the Experience Optimization feature is installed on your CMS before running the DXA XO Module's cms-import.ps1.

If the Experience Optimization feature is installed, it should create XO TBBs in /Building Blocks/Default Templates/Experience Optimization for newly created Publications.

If you installed the XO feature after the DXA BluePrint was created, you have to use the SDL Template Builder to Create/update the Default Templates in the DXA BluePrint root Publication.

  • Hi Rick, I am Unable to find correct version of SDL Optimization module with DXA 1.4, Can you guide to me a link from where I can download the Correct Version. – Piyush Jain Jan 6 '17 at 9:57
  • Hi Rick, Thanks for the Update, It seems that this Link have DXA 1.4 .Net Version only, I am Looking for DXA 1.4 Java version for the same. Can you please help on this. – Piyush Jain Jan 6 '17 at 12:58
  • These DXA Module Distributions are for .NET and Java. Indeed, they also contain .NET web application artifacts (and installer). For Java, the artifacts (for all versions) are in Maven Central. – Rick Pannekoek Jan 6 '17 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.