9

I am trying to copy/replace a file via WebDav.

I have succefully mapped the drive and navigated to the folder, copied my desired file to my desktop, modified it slightly via Notepad and now trying to copy it back into the CM. After agreeing to the "File already exists. Would you like to copy and replace?" dialog the system crunches for some time and then I get an error:

"Error x80070780: The file cannot be accessed by the system":

enter image description here

I have tried this with an xsd, so to rule out a possibility of an xml syntax error I made a very simple edit to a dwt instead (added a character in the template file). However, the same error persists for both types. So I don't think it's due to any kind of syntax issues with what's in the file.

Using Tridion 2011 SP1 HR1. I have admin rights in the CM, but no direct access to the CM server, nor the IIS console to check the logs (everything is locked down and requires annoying tickets/paperwork - thank you Sarbanes Oxley!)

I have googled the standard Webdav causes of this error (most frequent being a problem when connecting over SSL and other IIS settings that don't apply to Tridon's WebDav since the docs say the Microsoft WebDav Extension must be disabled: http://sdllivecontent.sdl.com/LiveContent/content/en-US/SDL_Tridion_2011_SPONE/concept_EB680229C02B40C88FFBCB111BA04EAC).

Any ideas please?

  • 1
    Can you upload any file (i.e. not the one that already exist)? I would advise you to try with Fiddler on, or try uploading something through code (amarchuk.blogspot.nl/2011/10/…). You can also try from another client machine, sometimes it helps – Andrey Marchuk Jun 6 '13 at 7:10
  • Good tip. I just tried that and it works. If it's a new file, then uploading is not problem... although WebDav is hella slow! – Nickoli Roussakov Jun 7 '13 at 1:52
3

Just a thought... Could it be that the item you have pulled is part of a BluePrint structure and the item is not localized?

That could explain why you can read the file but not write it back?

  • Good tip. Though I made sure I was in the right pub and nothing was localized – Nickoli Roussakov Jun 6 '13 at 14:39
2

When I was browsing about your issue, I come across with the below information and thought that it might be useful to you.

The issue might be with the "Require Lock for Writing" setting under WebDAV Settings. It needs to be False if clients are connecting to the share directly in Explorer (via mapped drive or Network Place).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.