I have included a link(www.google.com) in the content which is part of Experiment; On webpage When i click this link it automatically gets converted to the below url which is fine http://{domain}/redirect/?Url=www.http://google.com&data=AXHGFETYUXLKG..

but it display below message on the browser and does not redirect to actual url which is www.google.com

No matching Localization found for URL 'http://mydxawebsite.com:92/redirect/'

1 Answer 1


For such URL to resolve, you have to ensure you have a Publication which maps to the Website root (you don't have to actually publish anything in that Publication, but just have a mapping in Topology Manager so a Localization can be resolved).

Alternatively, you can change the redirect URL prefix in smarttarget_conf.xml so it matches the URL path of one of your mapped Publications. You will have to change the ignore-urls in the web.config accordingly.

  • I tried option-2 first, and set trackingRedirectUrl="/us/en/redirect/" in smarttarget_conf.xml of deployer,xo management service,xo query service,sdl content service, website/bin/conf. Also in web.config ingnore-urls value to "us/en/redirect". But still the urls for the published content is pointing to http://{domain}/redirect/ on the webpage. I re-published the content, restarted all services where smarttarget_conf is updated. Jan 19, 2017 at 7:11
  • You should only have to change the smarttarget_conf.xml used in the Web App. Jan 19, 2017 at 18:14
  • Hi Rick; Even I make the change only in Web App unfortunately its not making any impact on the the final url value generated on webpage. In smarttarget_conf.xml I am updating the value for attribute "trackingRedirectUrl". Is this not the right place ? Jan 20, 2017 at 10:00
  • Yes, that is the setting I meant. Frankly, I haven't tried it myself and am not a XO expert. I'm hoping an XO expert will weigh in soon. :-) Jan 20, 2017 at 10:28
  • Hi Rick ; Thanks for quick reply; I tried option 1. And its trying to fetch item "redirect" from Publication mapped to website Root and failed DEBUG - Request URL 'dev-sdl.mytest.com:92/redirect/…' maps to Localization [14 ('English')] INFO - Item '/redirect/index' not found for Localization '14' ERROR - Item '/error-404/index' not found for Localization '14' Jan 20, 2017 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.