0

I am trying to install the DD4T templating code to my cms sever (See https://github.com/dd4t/DD4T.TridionTemplates/releases). I am having an issues when it asks for "Enter the URI of the folder where you want to store the DD4T template building blocks:".

I have tried \Tridion\bin\client and many different URI combinations. I have tried remoting in through cmd from a my local machine and directly running the bat file (install-templates.bat) on the server itself. But every time I get invalid URI.

Does anyone know what to put in here for the URI if: 1. I am running the install-templates.bat from remote machine? 2. Or on the server itself?

Thanks, Robert

2

Apparently it needs to be the tcm uri of the folder Example: tcm:7-2056-2

1

This isn't intended as a specific answer but the comment size/format was is too restrictive - and I feel could still be useful if anyone stumbles across this specific question.

The answer - as noted by Robert is that the TCM URI (the fully qualified Tridion ID tcm : publication_id - internal_id - type_id) is usually expected in the scripts.

The use of the TCM URI will usually be the case for any 'references' in scripted files used for Tridion; sometimes you can substitute for the WebDAV URL.

The WebDAV URL is preferable if you change the script internally rather than rely on human input - given the WebDAV path doesn't change through Content Porter but the TCM IDs can. This would allow you to execute the same script through your environments without intervention/risk of typos.

CAN -> if you see the same TCM ID throughout environments it's simply down to

  • chance - usually for the earliest created items such as initial Publications etc. or
  • copied data - where a specific environment was backed-up and restored to another environment
    • noting that once new items are created in each environment they will have IDs (the centre part of the TCM URI) relative the sequence in which they are created
0

Yes, "URI" often refers to the tcm ID.

Another thing that can trip you up - if using localhost, you may need to add "http://" in front to get a valid prefix for the URI. In my case, it was http://localhost:81/ that I needed (not localhost:81, as it appears in the CME)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.