1

I moved tridionThumbnailCache folder and multimedia image into D drive and updated <Tridion.ThumbnailDirectory>D:\Tridion\tridionThumbnailCache</Tridion.ThumbnailDirectory> in System.config.

Now I am facing issue multimedia component image not displaying in CME due to folder permission issue.

Looking solutions for tridionThumbnailCache permission updates.

  • Have you set that the same user have same permissions over new folder just as over old one? – Marko Milic Feb 9 '17 at 8:01
  • I moved old folder into another d drive. – Sudhakar Rao Feb 9 '17 at 17:07
  • 2
    If you move a Folder with inherited permissions, you can effectively change its ACL. Try using ProcMon to see why the file access fails. – Rick Pannekoek Feb 10 '17 at 9:06
  • @RickPannekoek yes i agree, also my point. Folder can change its inheritance if moved. Also, you should check which user should have write permissions over tridionThumbnailCache folder. I guess that it should be MTSUser. – Marko Milic Feb 10 '17 at 9:22
  • I guess it should be NT AUTHORITY\NETWORK SERVICE. – Rick Pannekoek Feb 10 '17 at 10:21
3

actually, they do. I worked this out with SDL support recently. you keep the thumbnail cache setting there. But that's a virtual path under IIS. What you do in IIS is set new virtual directory to your custom location.

You can do that in PowerShell like this:

Import-Module WebAdministration
New-WebVirtualDirectory -Site "SDL Web" -Name "ThumbnailCache" –Application "WebUI" -PhysicalPath "D:\Tridion\tridionThumbnailCache"
| improve this answer | |
1

SDLWeb not support to custimize the Thumbnail cache directory due to permission issue. I revert my custimized change and using default directory and permissions.

    <!-- Thumbnail cache directory -->
    <Tridion.ThumbnailDirectory>/ThumbnailCache</Tridion.ThumbnailDirectory>
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.