When I start our .NET website, I see the following error in the Event Viewer:

enter image description here

This results in no Tridion logging and links that can't be resolved. I already checked the JAVA_HOME environment variable, and that one is correct. The following Java version is installed:

enter image description here

In the registry editor the following information is found:

enter image description here

I also check the license file and the references to the license file in all the config files and they are also correct.

  • What is the installation path of your JRE? Does it match what is shown in the Registry for the JavaHome variable? Commented Feb 21, 2017 at 15:41
  • Yes, it does match (C:\Program Files\Java\jdk1.7.0_79) Commented Feb 21, 2017 at 19:21
  • 1
    Hmm, but in your screenshot of the registry above the path is shown as "C:\Program Files\Java\jre7" Commented Feb 21, 2017 at 23:35
  • You're right. I am confused now. I changed the JavaHome in registry to C:\Program Files\Java\jdk1.7.0_79 also, but it's still not working (after restart of server). But I am confused now because the jre7 folder has only a lib and a bin folder in it. And the jdk1.7.0_79 folder has a bin, lib, but also a jre filder (which contains its own lib and bin). Should the javahome path then be C:\Program Files\Java\jdk1.7.0_79\jre? Commented Feb 22, 2017 at 8:43
  • Try taking off the "\jre" at the end of the path, i.e. keep "C:\Program Files\Java\jdk1.7.0_79". Also have this path listed under the JavaHome key for all Java 7 Registry items. Commented Feb 22, 2017 at 15:42

1 Answer 1


Finally found the solution.

The other applications on the webserver were 64-bit applications. This application was 32-bit. So I had to install Java 32-bit.

It didn't work at first time, because the 32-bit java version has to match exactly with the installed 64-bit version. So for instance, Java 7 U79 (64-bit) will not work with Java 7 U51 (32-bit).

After installation my Registry look liked the following:

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.