1

While configuring Deployer environment on Topology manager using the commandlet Add-TtmCdEnvironment, I am running into the below issue. I have done a quick install of microservices as mentioned of web 8.5

PS C:\Softwares\SDL Web 8.5\SDL Web 8.5\Database\mssql> Add-TtmCdEnvironment -Id devdeployer -EnvironmentPurpose Staging -DiscoveryEndpointUrl http://devdeployer:8082/discovery.svc -AuthenticationType OAuth

cmdlet Add-TtmCdEnvironment at command pipeline position 1
Supply values for the following parameters:
ClientId: cmuser
ClientSecret: Reg1str@t10nP@ssw0rd
Add-TtmCdEnvironment : Unable to save item of type 'CdEnvironmentData' with id 'devdeployer'.
One or more errors occurred.
Authorization failed while attempting to communicate with CD Discovery Service 'http://devdeployer:8082/discovery.svc'. Please make sure the proper credentials have
been configured in the CD Environment 'devdeployer'.
One or more errors occurred.
Failed to authenticate with the token provider.
At line:1 char:1
+ Add-TtmCdEnvironment -Id devdeployer -EnvironmentPurpose Sta ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Tridion.Topolog...ironmentCommand:AddCdEnvironmentCommand) [Add-TtmCdEnvironment], DataServiceException
    + FullyQualifiedErrorId : Tridion.TopologyManager.Automation.AddCdEnvironmentCommand

I have also configured and registered the token service. Not sure what else I am missing.

2

Detailed description of Roles is documented here.

registration user is used only for registering capabilities in discovery service.

When setting up topology, you need to use cmuser Reference here

For retrieving content (CD side), you should be using cduser

Also you can check this on Roles

| improve this answer | |
1

Documentation is missing lot of steps. Checked cd_ambient_conf.xml for the password for cmuser and got it.

| improve this answer | |
  • The answer here makes things simpler and helps to remember use of different users. – Ashutosh Feb 23 '17 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.