We are trying to configure multi-language sites in DXA 1.7 and web 8.5 combination. We have publications each for a language and one DXA app talking to the Discovery service to render the sites. We tried configuring Added cd_dynamic_conf.xml as below :

            <Publication Id="28">
                 <Host Protocol="http" Domain="www.domain.com" Port="80" Path="en" />                           
            <Publication Id="29">
                 <Host Protocol="http" Domain="www.domain.com" Port="80" Path="es" />

And restarted the Application pool.On CMS, we configured the publishing path for each publication as en and es accordingly.

Under publication propoerties in Publishing tab, configured publishing target Staging with URL Path segment as "en" and "es" correspondingly however, when we try accessing the URL - http://www.domain.com/en/list.html we are seeing error like

No matching localization found.

Please help on this

We followed as suggested,but when we try to access our page with http://www.domain.com/en/index.html we are getting below error

Home Internal Server Error

An error has occurred. We apologize for any inconvenience.

In Logs i was able to the below error : Item '/en/error-404/index' not found for Localization '28'

Thanks Nuno.When we used Site Manager ,it worked and we are able to http://www.domain.com/en/index.html

But we are facing issue while accessing with the localhost(DXA code) http://www.domain.com:port/en/index.html

Getting "Item '/system/config/_all.json' not found for Localization '28'"

Should we add any configuration to run the code from DXA. Please suggest.

  • 1
    I see in the error message that you are trying to map to the default HTTP port. You might be suffering from this issue: tridion.stackexchange.com/questions/14563/… Commented Apr 7, 2017 at 14:23
  • What's the output of running Get-TtmWebsite on the CM? As @RickPannekoek says, there is no cd_dynamic_conf.xml anymore (well, there is, but not needed/used for DXA and 8+)
    – Nuno Linhares
    Commented Apr 7, 2017 at 17:31
  • Can you expand on "we are facing issue while accessing with the localhost" - if you're using http://localhost then you need to add a URL mapping to Topology Manager - see this comment from Rick: tridiondeveloper.com/…
    – Nuno Linhares
    Commented Apr 11, 2017 at 10:29

2 Answers 2


If you are using DXA, please check the following configurations for the localised publications,

  1. In Publication Properties, verify the PublicationPath and PublicationUrl values
  2. In each of the language publications, ensure you have localized the following component in the "Localization configuration component" and set the culture properly {Publication Name}\Building Blocks\Settings\Core\Site Manager\
  3. In publication properties, open publish tab and set the "URL Path Segment" correctly
  4. Publish the changed items also the following pages(_Navigation, PublishSetttings page, Sitemap, Publish Html Design)
  5. do an admin/refresh in the website
  6. Turn on the log level to debug and check the site.log file for specific errors if any

Hope this helps to resolve the errors

  • 1
    For clarity: cd_dynamic_conf.xml is no longer used to configure Publication mappings in SDL Web 8 and higher; Topology Manager is used instead and above procedure results in Publication mappings being created in Topology Manager. Commented Apr 7, 2017 at 14:18

I've just quickly tested creating a new publication using the Site Wizard (Left Nav -> Sites -> Create) and defined a context url of /somelanguage - and magic, it all worked as expected, including getting the site loaded after publishing.

Did not have to fiddle with ANY configuration file, or Topology Manager mappings (which is obviously the reason why TTM exists, that you can do all of this automatically).

Have you tried doing it via the site wizard?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.