2

When we call http://<host>:<port>/client/v4/content.svc/GetPublicationMappingsFunctionImport?Url='https://www.<host>.be' we get the following error:

<?xml version="1.0" encoding="UTF-8"?>
<metadata:error xmlns="http://docs.oasis-open.org/odata/ns/metadata">
    <metadata:code>9000</metadata:code>
    <metadata:message>java.lang.NullPointerException: null<metadata:message>
</metadata:error>

Within the logging of the content service we get the following stacktrace:

2017-04-13 15:55:35,345 ERROR DynamicStorageMappingsStrategy - Malformed url:java.net.MalformedURLException: null
    at java.net.URL.<init>(URL.java:627) ~[na:1.8.0_92]
    at java.net.URL.<init>(URL.java:490) ~[na:1.8.0_92]
    at java.net.URL.<init>(URL.java:439) ~[na:1.8.0_92]
    at com.tridion.dynamiccontent.publication.mappingsstrategy.impl.DynamicStorageMappingsStrategy.resolvePublicationMapping(DynamicStorageMappingsStrategy.java:44) ~[cd_dynamic-8.1.1-1008.jar:8.1.1-1008]
    at com.tridion.dynamiccontent.publication.mappingsstrategy.MappingsStrategyContext.resolvePublicationMapping(MappingsStrategyContext.java:27) [cd_dynamic-8.1.1-1008.jar:8.1.1-1008]
    at com.tridion.dynamiccontent.publication.mappingsstrategy.MappingsStrategyContext.resolvePublicationMapping(MappingsStrategyContext.java:30) [cd_dynamic-8.1.1-1008.jar:8.1.1-1008]
    at com.tridion.dynamiccontent.publication.MappingsResolverImpl.getPublicationMappingFromUrl(MappingsResolverImpl.java:69) [cd_dynamic-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.web.content.datalayer.dynamic.DynamicContentProvider.getPublicationMappingFromUrl(DynamicContentProvider.java:39) [content-common-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.web.content.odata.function.dynamic.GetPublicationMappingsFunction.doContentServiceOperation(GetPublicationMappingsFunction.java:42) [content-common-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.web.content.odata.function.dynamic.GetPublicationMappingsFunction.doContentServiceOperation(GetPublicationMappingsFunction.java:20) [content-common-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.web.content.odata.ContentServiceOperation.doOperation(ContentServiceOperation.java:36) [content-common-8.1.1-1008.jar:8.1.1-1008]
    at com.sdl.odata.processor.ODataFunctionProcessorImpl.doFunction(ODataFunctionProcessorImpl.java:63) [odata_processor-2.0.5-1002.jar:2.0.5-1002]
    at com.sdl.odata.service.actor.ODataQueryProcessorActor$$anonfun$receive$1.applyOrElse(ODataQueryProcessorActor.scala:36) [odata_service-2.0.5-1002.jar:2.0.5-1002]
    at akka.actor.Actor$class.aroundReceive(Actor.scala:480) [akka-actor_2.11-2.4.1.jar:na]
    at com.sdl.odata.service.actor.ODataQueryProcessorActor.aroundReceive(ODataQueryProcessorActor.scala:29) [odata_service-2.0.5-1002.jar:2.0.5-1002]
    at akka.actor.ActorCell.receiveMessage(ActorCell.scala:526) [akka-actor_2.11-2.4.1.jar:na]
    at akka.actor.ActorCell.invoke(ActorCell.scala:495) [akka-actor_2.11-2.4.1.jar:na]
    at akka.dispatch.Mailbox.processMailbox(Mailbox.scala:257) [akka-actor_2.11-2.4.1.jar:na]
    at akka.dispatch.Mailbox.run(Mailbox.scala:224) [akka-actor_2.11-2.4.1.jar:na]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [na:1.8.0_92]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [na:1.8.0_92]
    at java.lang.Thread.run(Thread.java:745) [na:1.8.0_92]
Caused by: java.lang.NullPointerException: null
2017-04-13 15:55:35,345 ERROR ODataFunctionProcessorImpl - Unexpected exception when executing a function.
java.lang.NullPointerException: null
2017-04-13 15:55:35,347 ERROR ODataRendererActor - Unexpected exception during response rendering - java.lang.NullPointerException: 'null'
java.lang.NullPointerException: null

Is there an extra parameter that we need to give?

The reason why we are doing this is to see why the favicon of our website is getting a Localization not found exception. All other assets work like a charm but our Production Live environment has a problem with the favicon (all other environments do not). Only difference being https (prod live) vs http (all the rest). When we backtrace the Localization exception we see that it goes wrong in the call above, so we want to know what it returns.

Kr,

Thomas

  • I would hazard a guess that you're using cd_dynamic to do publication resolution in the CIS and there's a problem in your cd_dynamic_conf.xml for the https binding? But if not - no idea :) – Rob Stevenson-Leggett Apr 13 '17 at 14:22
  • 1
    can you turn on DEBUG logging in Content service and see what is the URL that is causing this issue ? From the error it appears that the failure is happening due to URL not in correct format. – vinayknl Apr 14 '17 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.