3

I have observed that our qservers (we have 2 of them) at times have high response time (60 seconds). This results in timeout exception which we observe in logs. Once i restart them, their response time get to about 70ms and everything works fine.

Is there something that I can do investigate why they get slow beside checking logs?

./bin/chk-up indexer will give me only response time, but not information WHY is response time so slow.

Thanks in advance.

3

I have checked fredhopper learning center (login required) and found couple of articles related to fredhopper monitoring and memory tuning:

Following fredhopper articles expain what proposed values for memory should be: https://www.fredhopper.com/learningcenter/display/learningcenter/Fredhopper+Memory+Settings https://www.fredhopper.com/learningcenter/display/learningcenter/Performance+Tuning+Fredhopper

  • Could you summarize the settings that worked for you, for the people who do not have a login to the Learning Center? – Peter Kjaer May 16 '17 at 8:20
  • @Marko, when was the last time the fredhopper indices were rebuilt? – Phil Medcraft May 16 '17 at 10:51
  • Hi @Philip, its good to hear from you. Its been about 2 months since we did reindex and push to live, but we haven't done rebuild of indices, so i think it was last done by you. Is there some recommendation in which intervals it should be done? – Marko Milic May 16 '17 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.