3

We imported the DXA 1.7 example content into our SDL Web 8.1 Content Manager using the provided import script. We installed the SDL Webservices and the DXA Webapp into our Windows Server 2012 CD environment and we successfully ran the DXA Example website on dxa.example (with host entry).

However when we change content using Experience Manager and the system finds a newer content version in the database, the "Update Preview" button starts to blink.

Upon pressing the button, following error message appears in the XPM frontend:

Unable to update the changes using OData Service. The remote server returned an error: (403) Forbidden.

The Ajax request throwing an error 500 in Chrome network tab:

Chrome Debugger

When inspecting the event logs on the Content Manager server, i can see following error:

enter image description here

It does not matter if we enabled/disabled OAuth, XPM still throws the same error. We played around with Topology Manager Cd/CmEnvironment and the linked authentication. We Tried Anonymous as well as OAuth registration, cduser, cmuser but all without success.

When we migrated from Tridion 2013 to Web 8 earlier, we had a similar error caused by the cd_ambient_conf.xml and a missing <cartridge>. We are currently using the config files that were provided by the DXA Example package.

Thank you for your help!

2

My first guess would be that your Preview Service (or Session-enabled Content Service) is not be correctly installed/configured, please note that it has a different cd_ambient_conf.xml than the DXA example website has, as the latter will not have (or need) the preview cartridge configured:

<Cartridge File="cd_webservice_preview_cartridge.xml" />

This cartridge is needed for the correct workings of the Preview Service/XPM, so I would suggest to validate it is correctly setup/configured, following the documentation of Web 8 (don't use anything from DXA for that, the Preview Service/XPM is a part of Web 8, and does not need to be changed for DXA): http://docs.sdl.com/LiveContent/content/en-US/SDL%20Web-v1/GUID-67492C01-F3E9-4CB8-97E4-B94613EE457E

(or http://docs.sdl.com/LiveContent/content/en-US/SDL%20Web-v1/GUID-B392E30C-7A2D-4C8F-80E3-43B29F5F891B for the Session-enabled Content Service)

  • This was the exact problem. After re-configuring the Preview Service, the OData error was gone. Thank you! – S. Gabriel May 30 '17 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.