I have just installed SDL Tridion 2013 SP1 and I have found a problem when I have started the application. I get the following errors:

enter image description here

Probably, this error comes from a problem with the connection with the Tridion_cm database, because I saw an error in the Event viewer that says:

A database error occurred while executing Stored Procedure "EDA_TRUSTEES_GETTRUSTEETOKEN". Cannot open the connection with "Tridion_cm" database. Session start error with the user 'TCMDBUser'.

Could you tell me any configuration which is probably wrong?


I restarted the machine after the Tridion installation finished. When I connect to the database with the TCMDBUser user I can only see two tables. On the other hand, if I connect to the same database with the admin user (sa) I can see all tables in the database.

3 Answers 3


Have you restarted the machine after Tridion installation?

Looking at the error, Tridion CM is not able to establish the connection to database.

Try to login to database using the username TCMDBUser. (If SQL Server, open sql server management studio, login as TCMDBUser, check whether the login succeeds and you are able to do a select operation on any of the tables in Tridion_cm database).

EDIT : When you run the powershell script to install the Tridion_cm database, I think you have provided different values to the following parameters

Database name. Default value is 'Tridion_cm':
Adding database login.
User name of database account. Default value is 'TCMDBUser': test
Enter password for the new database login:

During installation, TCMDBUser has been specified as the Tridion_cm user which might be causing permission related issues now.

As Peter Kjaer suggested, so may be it best to reinstall DB Scripts as TCMDBUser and try once again to see if that helps to resolve the issue

  • Yes, I restarted the machine after Tridion installation finished. When I connect to the database with this user I only can see 2 tables. On the other hand, if I connect to the same database with the admin user (sa) I can see all tables in the database. What could be the problem? Commented May 31, 2017 at 7:59
  • So, you got to know the root of the problem. So, if you add the missing permissions to the database for TCMDBUser, you r problem will get solved You may follow steps as in below link: esha.zendesk.com/hc/en-us/articles/…
    – Rajesh
    Commented May 31, 2017 at 12:59
  • Thank you Rajesh, but after review the permission problem in database (i assignTCMDBUser the permissions to view all tables in Tridion_cm), I still get the same error: "$config is not defined at ProxyView" and by default Tridion put "Default User" at the top of the page. Commented Jun 1, 2017 at 9:14

If TCMDBUser only sees two tables, there's your problem. The user needs to have rights for all of the tables (and Stored Procedures etc.)

This is all set up by the database scripts, so either something went wrong there or the security for the user was changed by someone afterwards.

Assuming you don't have any data you would care about losing, I would suggest simply deleting the database and running the "Install Content Manager database.ps1" script again. Make sure it doesn't throw any errors...


TCMDBUser needs to have role membership of "db_datareader" and "db_datawriter" on Tridion_cm database.

Then it should only have SELECT, UPDATE, DELETE AND INSERT permissions on BINARIES and TDS_DB_INFO tables configured in the "Securables" of this DB user

Make sure your DB server allows remote connection to it. To check that, from CMS server, run command line "telnet dbserver 1433", or if you haven't got telnet installed, create a dummy "test.udl" file on your CMS server, double click it, put your DB connection details in, and test.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.