Our editors tried searching some content in Tridion CM search and sometimes they did not get any results for a particular word. Upon investigation we found that the last word was indexed along with fullstop (.)

For eg, consider the below sentence:

Lorem ipsum dolor sit amet, consectetur adipiscing elit.

So if we tried searching 'elit', there were no results. However if we try 'elit.', we were able to get the results.

Is fullstop (.) also indexed along with last word? Is this default behaviour?

1 Answer 1


I just tried this on 2013 SP1 and the behavior is indeed the same.

Running Solr Analyzer shows that a full stop remains after processing: http://localhost:8983/#/tridion/analysis?analysis.fieldvalue=elit.&analysis.query=elit.&analysis.fieldname=CatchAll

The problem is that "text" field type in Solr schema does not have a filter which removes delimiter characters (usually solr.WordDelimiterFilterFactory or lately solr.WordDelimiterGraphFilterFactory).

You should be able to fix this by adding delimiter filter to "text" field type in the schema (%TRIDION_HOME%\Tridion\solr-home\tridion\conf\schema.xml), but it's quite possible that it was left out for a reason (for example, to be able to search for a namespace in a template).

There's also a workaround - to use asterisks in the search field: *elit* should return the expected results.

  • The workaround looks to be a better option at the moment. Thanks :) Commented Jun 9, 2017 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.