3

I'm configuring Web 8.5's scalable deployers, and see that even though the Adapter specified in deployer-conf.xml for endpoint and workers, logging indicates that filesystem adapter is being used instead. Suggestions welcome.

Details are:

  • Transport core log has below (note the 406 http error) 2017-06-09 02:56:56,461 DEBUG TransportSender - Starting sending of transportPackage C:\Tridion\bin\transactions\tcm_0-3076-66560.Content.zip to destination PD33rz1kcc+/S9ve/GrQZQ==. 2017-06-09 02:56:56,961 ERROR BaseHTTPSTransportConnector - Unable to send TransportPackage to url: http://localhost:8084/httpupload cause: HTTP/1.1 406

  • Zip files are being stored to the local Redis database

  • Webapp is DXA 1.7

  • From Publishing Queue, error "Transporting Failed: could not transport tcm_0-3077-66560.Content.zip using HTTPS"

  • From Deployer endpoint, see log event 2017-06-08 13:38:16,177 DEBUG StatePropertiesConfigurer - Resolving mssql adapter for the state store 2017-06-08 13:38:41,078 INFO DefaultQueueProvider - Found adapter with id: FileSystem and type: com.sdl.delivery.deployer.queue.filesystem.FSQueueAdapter@5bbc033f 2017-06-08 13:38:41,078 INFO DefaultQueueProvider - Found adapter with id: JMS and type: com.sdl.delivery.deployer.queue.jms.JMSQueueAdapter@5408fca1 2017-06-08 13:38:41,090 DEBUG JMSDeploymentQueue - Skipped monitoring startup for the JMS Queue [Id=ContentQueue]. It is endpoint instance.

  • The Deployer endpoint deployer-conf.xml file (and counterparts in Deployer workers) is configured to use RedisBlobStorage as opposed to Filesystem for Adapter, snippet below

<BinaryStorage Id="RedisStorage" Adapter="RedisBlobStorage">
    <Property Name="Host" Value="localhost"/>
    <Property Name="Port" Value="6379"/>
    <Property Name="Timeout" Value="20000"/>
</BinaryStorage>
<State>
    <Storage Adapter="mssql" driver="com.microsoft.sqlserver.jdbc.SQLServerDriver">
        <Property Name="host" Value="localhost"/>
        <Property Name="port" Value="1433"/>
        <Property Name="database" Value="xxx"/>
        <Property Name="user" Value="xxx"/>
        <Property Name="password" Value="xxx"/>
    </Storage>
</State>
<Queues>
        <Queue Default="true" Verbs="Content" Adapter="JMS" Id="ContentQueue">
            <Property Name="Workers" Value="11"/>
        </Queue>
        <Queue Verbs="Commit,Rollback" Adapter="JMS" Id="CommitQueue">
            <Property Name="Workers" Value="11"/>
        </Queue>
        <Queue Verbs="Prepare" Adapter="JMS" Id="PrepareQueue">
            <Property Name="Workers" Value="11"/>
        </Queue>
        <Adapter Id="JMS">
            <Property Name="JMSConnectionFactoryBuilderClass"
                      Value="com.sdl.delivery.spring.configuration.jms.ActiveMQConnectionFactoryBuilder" />
            <Property Name="JMSUri" Value="tcp://localhost:8161" />
            <Property Name="Username" Value="xxx"/>
            <Property Name="Password" Value="xxx"/>
            <Property Name="ReceiveTimeout" Value="200"/>
        </Adapter>
    <Workers>
    </Workers>
</Queues>
  • Have you seen Hao Peng's posts on community.sdl.com regarding Redis? Not sure they address this specifically, but seem pretty thorough: community.sdl.com/solutions/content-management/tridion/… – Nuno Linhares Jun 9 '17 at 12:44
  • Have read the three posts, certainly helpful but nothing directly applicable. I did check whether my DXA 1.7 webapp web.config had any applicable redis config options for my scenario, does not. The several redis params which are in web.config are specific to client-side caching. – Terry Kim Jun 9 '17 at 13:04
3

Issue resolved after using JMSUri value below in the deployer-conf.xml files, where port 61616 is used instead of incorrect admin port 8161.

tcp://localhost:61616

In hindsight, the FileSystem Adapter log entry was a red herring... Adapter was found, but was not the cause of error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.